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WEBSITE DESIGNING 

What is a Website? 
A website is a collection of web pages that are connected and accessible 
through the internet using a web browser. Websites can contain text, images, 
videos, and interactive elements, and they are usually identified by a unique 
domain name. 
Domain + Hosting = Website 
Example: https://www.odmt.in/  
 

What is a Domain? 
Domain means Name of the website. A domain is the unique web address that 
people use to visit a website. It is what users type into their browser’s address 
bar to access a site. For example, https://www.odmt.in/ is a domain. 

How Does a Domain Work? 

When you enter a domain (e.g.,https://www.odmt.in/) into your browser, it 
connects to a Domain Name System (DNS). 

The DNS translates the domain name into an IP address (e.g., 192.168.1.1), 
which identifies the server where the website is hosted. 

Your browser then loads the website from that server. 

Parts of a Domain Name 

Example: https://www.odmt.in/ 

WWW  –  (World Wide Web) A common subdomain (optional). 

odmt   –  The unique name chosen for a website. 

.in        –  The Top-Level Domain (TLD), also known as the domain extension 

3 

https://www.odmt.in/
http://www.google.com
https://www.odmt.in/
https://www.odmt.in/
http://www.example.com
https://www.odmt.in/


 

How to Get a Domain? 

You can buy and register a domain from domain registrars like:​
✔ Bluehost​
✔ Hostinger​
✔ Go Daddy​
✔ Big rock 

What are Domain Extensions? 

A domain extension is the ending part of a website address. It specifies the 
type or purpose of a website. 

         .com – Commercial or general use 

 .org – Nonprofits & organizations 

 .net – Networking & technology 

 .edu – Educational institutions 

 .gov – Government websites 

Country Code: 

.us (United States), .uk (United Kingdom), .ca (Canada), .in (India) 

Domain name Techniques: 

Choosing a good domain name is important for your website’s success. A short 
domain name (e.g., google.com) is easier to remember. 

Avoid long or complicated names. Use words that describe what your website is 
about. 

Short and simple (less than 15 letters) 

Easy to spell and pronounce 

Related to your business or niche 
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 Free of numbers and hyphens 

 Available for registration 

Difference between https vs http? 

Both HTTP and HTTPS are protocols used to transfer data between a web 
browser and a website. 

HTTP (HyperText Transfer Protocol) is a protocol used for communication 
between web browsers and servers.It allows users to load web pages and 
transfer data.Data sent through HTTP is not encrypted, making it vulnerable to 
hackers.No encryption, meaning data (like passwords) can be stolen.Not secure 
for online transactions or sensitive information.Most modern browsers now warn 
users when visiting HTTP sites. 

HTTPS (HyperText Transfer Protocol Secure) is a secure version of HTTP.It 
uses SSL encryption to protect data.Ensures that data sent between a browser 
and a website is safe from hackers.Encrypts data to prevent hacking.Improves 
user trust and security.Helps with SEO ranking (Google prefers HTTPS 
websites).Required for online payments and sensitive transactions. 

SSL = secured socket layer 

What is a Server ? 
Server means where all our websites are present . It stores, processes, and 
delivers websites to users over the internet. When someone enters a website 
URL in a browser, the web server retrieves the requested web page and sends it 
to the browser for display. 
How Does a Web Server Work with WordPress? 
A user types your website’s domain (e.g., example.com) in a browser. 
The web server receives the request and retrieves the necessary WordPress 
files. 
The PHP processor runs the WordPress core, and the database server 
(MySQL/MariaDB) fetches the content. 
The web server sends the final web page back to the user’s browser 
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What is Hosting? 
Hosting means Space inside the server. Hosting refers to the service that 
allows individuals and organizations to publish their websites on the internet. It 
involves storing your website's files (such as images, videos, and text) on a 
server and making them accessible to visitors through a domain name (like 
https://www.amazon.in/) 

Types of Hosting 

Shared Hosting: Many websites share one server (like sharing a house with 
roommates).Cheap, but shared with others. 

VPS (Virtual Private Server) Hosting: Many websites share one server (like 
sharing a house with roommates).More control, but still sharing. 

Dedicated Hosting: You get a whole server to yourself (like owning a              
house).The best performance, but costly. 

Step-by-Step Guide to Buying a Domain and  Hosting on 
Bluehost: 

Step 1: Visit the Bluehost Website 
Open your web browser and go to www.bluehost.com. 
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Step 2: Choose a Domain Name 

Now, you need to register a domain name. You have three options: 

Create a new domain – Type your desired domain name in the search bar (e.g., 
yourwebsite.com). 

Use an existing domain – If you already have a domain from another provider, 
enter it here. 

Skip and choose later – If you don’t have a domain yet, you can choose one 
later. 

 
 

Click “Search” after Entering your domain name and check it is available or not. 
After that You have to Choose a Hosting Plan. 
 
 
Step 3: Choose a Hosting Plan 
Bluehost offers different hosting plans. Since you are looking for shared hosting, 
you will see these options: 
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Basic Plan            – Suitable for one website (recommended for beginners). 
Choice Plus Plan – Good for multiple websites. 
Online store Plan – Includes domain privacy and site backup. 
Pro Plan                – Best for high-performance websites. 
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Click “Select” to proceed 
 

 

Again Entering your domain name here. 

 

Step 4: Enter Your Account Information 

Fill in your personal details, such as: 

First Name, Last Name 

Business Name (optional) 

Country, Address, Phone Number 

Email Address (Important! Bluehost will send login details here 
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Step 5: Choose Your Package and Extras 

You'll see your selected plan and pricing options: 

12 months (1 year) – Cheaper upfront, but renewal costs are higher. 

36 months (3 years) – Best long-term value, lower monthly cost. 
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After Submitting your details you are redirected to: 

Step 6: Enter Payment Details 

1.​Enter your credit/debit card details (Visa, MasterCard, or PayPal). 
2.​Check the Terms and Conditions box. 
3.​Click “Submit” to complete your purchase 

 

Step 7: Log in to Your Bluehost Account 

Go to www.bluehost.com and click “Login” at the top-right corner. 

Enter your email or rootdomain and password (from the confirmation email). 

Click “Login” to access your Bluehost dashboard. 

 

 Step 8: Install WordPress (For Website Setup) 

In your Bluehost Dashboard, find the WordPress Install option. 

Click “Install WordPress” and follow the setup instructions. 
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Choose your domain and click Install. 
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How to login to your wordpress Dashboard: 
https://www.website.in/wp-admin 
 

 

 

Basic WordPress Website Structure: 
When you create a website in WordPress, it has a basic structure that includes 
Pages, Themes, Menus, and Customization Options. Here’s a simple guide to 
understanding how WordPress works: 

Pages(Static Content): 
Pages are used for static content that doesn’t change often (e.g., Home, About 
Us, Contact). 
Home Page – The main page visitors see first. 
About Us – Information about your business or brand. 
Services/Products – Describes what you offer. 
Blog – If you post regular articles or updates. 
Contact Us – Includes a contact form, email, or address. 
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How to Create a Page in WordPress? 
Go to WordPress Dashboard → Click Pages → Add New. 
Enter a title (e.g., "About Us") and write content. 
Click Publish to make it live. 
 

 

Themes(Website Design): 

A theme controls how your website looks (layout, colors, fonts). 

WordPress has free and paid themes. 
 
How to Change a Theme? 
Go to Dashboard → Appearance → Themes. 
Click "Add New" to browse themes. 
Click "Install", then "Activate" your chosen theme. 
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Menus (Website Navigation): 

Menus help visitors navigate your website. 

You can add Pages, Posts, Categories, or Custom Links to a menu. 

How to Create a Menu in WordPress? 

Go to Dashboard → Appearance → Menus. 

Click Create a New Menu and give it a name (e.g., "Main Menu"). 

Add Pages, Posts, or Custom Links to the menu. 

Select the menu location (e.g., Header or Footer). 

Click Save Menu 
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Customize (Website Settings & Design): 

The Customizer allows you to edit your website’s appearance and settings in 
real-time. 

How to Customize Your WordPress Site? 

Go to Dashboard → Appearance → Customize. 

From here, you can edit: 

​Site Identity (Logo, Site Title, Tagline) 
​Colors & Fonts 
​Header & Footer 
​Homepage Settings 
​Menus & Widgets 

Click Publish to save changes. 
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Plugins: 
In WordPress, plugins are add-ons or extensions that enhance the 
functionality of a website.You can install plugins directly from the WordPress 
Plugin Directory or upload premium plugins from third-party providers. 
 

What do plugins do?  
Add new features to a website 
Enhance the functionality of a website 
Allow users to create sites without writing code 
 

How do I install a plugin?  
Go to the admin dashboard 
Select Plugins > Add New 
Search for a plugin or browse suggested plugins 
Click Install and Activate 
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Wp forms: 

WPForms is a popular WordPress plugin used to create contact forms.t is 
known for its drag-and-drop interface, making it beginner-friendly and highly 
customizable. 
 

How to Install WPForms in WordPress? 
Step 1: Install and Activate WPForms 
Log in to your WordPress dashboard. 
Go to Plugins > Add New. 
In the search bar, type WPForms. 
Click Install Now and then Activate. 
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Once activated, you will see a new WPForms menu in your dashboard. 
 
Step 2: Create a New Contact Form 
Go to WPForms > Add New. 
Enter a name for your form (e.g., "Contact Us Form"). 
Choose a template: 
Blank Form (Start from scratch) 
Simple Contact Form (Recommended for beginners) 
Newsletter Signup Form, Survey Form, etc. 
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Step 3: Customize Your Form (Drag & Drop Builder) 

Drag and drop fields from the left panel to your form.​
 Common fields to add: 

Name (Text field) 

Email (Email field) 

Message (Paragraph text field) 

Phone Number (Optional) 

Click on any field to edit its label or make it Required. 
 

Step 4: Configure Form Settings 

Go to the Settings tab.​
Under General Settings, change the form title and button text if needed.​
Under Notifications, enter your email to receive form submissions.​
Under Confirmations, set a thank-you message or redirect users to a custom 
page after they submit the form. 

Click Save when done. 

Step 5: Add the Form to a Page or Post 

Open the page where you want to add the form (e.g., Contact Us page).​
Click on + Add Block (if using Gutenberg).​
Select the WPForms Block.​
Choose the form you just created from the dropdown.​
Click Publish or Update the page. 

Your form is now live!  
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CRM Entries plugin:   
A CRM Entries Plugin for WordPress is a tool designed to integrate a Customer 
Relationship Management (CRM) system within your WordPress website. The 
plugin allows you to manage and track customer interactions, store contact 
details, and handle leads, sales, or support cases directly from the WordPress 
dashboard. 

Install the Plugin: Like any WordPress plugin, you start by installing and 
activating the CRM plugin.  

 

View Form Submissions in the CRM: 
CRM Dashboard: Once the form submission in wpforms, you can view it under 
your Leads, Contacts, or Customers section in your CRM plugin. 
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Collect.chat Plugin: 
Collect.chat is a chatbot plugin for WordPress that allows businesses to 
automate conversations with website visitors. It helps collect leads, book 
appointments, and provide customer support without human intervention. 
 

How to Install & Use Collect.chat on WordPress (Step-by-Step) 
 
Step 1: Install Collect.chat Plugin 
Log in to your WordPress dashboard. 
Go to Plugins > Add New. 
Search for Collect.chat. 
Click Install Now and then Activate. 
 

 
 
Step 2: Create a Chatbot on Collect.chat 
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Go to Collect.chat's website (https://collect.chat) and create an account.​
Click on Create New Bot.​
Use the drag-and-drop builder to design your chatbot flow: 

Add Welcome Messages 

Ask questions (Name, Email, Phone, etc.) 

Offer multiple-choice options 

Enable appointment booking​
Click Save & Publish when done. 
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Step 3: Connect Chatbot to WordPress 

Go to Collect.chat Dashboard > Embed Code.​
Copy the chatbot embed code.​
In WordPress, go to Settings > Collect.chat.​
Paste the embed code and Save Changes. 
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WhatsApp Click to Chat Plugin: 

The WhatsApp Click to Chat plugin allows visitors to start a conversation with 
you on WhatsApp directly from your WordPress website. It helps businesses 
provide real-time customer support, generate leads, and increase 
conversions by making communication easier. 
 

How to Install and Set Up WhatsApp Click to Chat Plugin 
(Step-by-Step) 
Step 1: Install the Plugin 
Log in to your WordPress Dashboard. 
Go to Plugins > Add New. 
Search for WhatsApp Click to Chat. 
Click Install Now and then Activate. 
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Step 2: Configure the WhatsApp Button 

 Go to Settings > WhatsApp Click to Chat.​
 Enter your WhatsApp phone number (with country code). Example: +1 
1234567890.​
Customize the Chat Button Text (e.g., “Chat with us on WhatsApp”).​
Add a Predefined Message (optional) – This message appears when users start 
a chat. Example: 

"Hello, I need help with my order!"​
Choose the Button Position (bottom left or right).​
Click Save Changes. 
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Translator Plugin: 
Translator Plugin allows your WordPress website to support multiple languages, 
helping you reach a global audience. 
 

How to Install and Set Up Translator (Step-by-Step Guide) 
 
Step 1: Install Translator Plugin 
Log in to your WordPress Dashboard. 
Go to Plugins > Add New. 
Search for Translator. 
Click Install Now and then Activate. 
 
Step 2: Configure Language Settings 
Go to Settings > Translator. 
Select your Default Language (the original language of your website). 
Click Add Language and choose the language you want to translate into. 
Click Save Changes 
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Step 3: Translate Your Website Content 
Click on Translate Site from the WordPress menu. 
A live preview of your website will open with an inline translation editor. 
Select any text on the page, and a translation box will appear. 
Enter the translated text manually or enable automatic translation. 
Click Save Translation. 
 

WP Reset Plugin: 
WP Reset  is a  recovery tool that helps  site owners, and testers reset, 
restore, and manage their websites efficiently. It allows users to reset their 
WordPress installation without deleting essential files. 
 
How to Install and Use WP Reset (Step-by-Step Guide) 
Step 1: Install WP Reset Plugin 
Log in to your WordPress Dashboard. 
Go to Plugins > Add New. 
Search for WP Reset by Sigma. 
Click Install Now and then Activate. 
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Step 2: Perform a Site Reset 
In the Reset tab, scroll down to the Site Reset section. 
Type "reset" in the confirmation box. 
Click Reset WordPress. 
Your site will reset, removing content but keeping WordPress core files. 
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Widgets in WordPress: 
Widgets in WordPress are small content blocks that you can add to sidebars, 
footers, headers, and other widget-ready areas of your website. They help 
you display dynamic content like menus, recent posts, search bars, social 
media links. 
How to Use Widgets in WordPress (Step-by-Step) 
Step 1: Access the Widgets Section 
Log in to your WordPress Dashboard. 
 Go to Appearance > Widgets. 
 You will see Available Widgets on the left and Widget Areas (Sidebar, Footer, 
etc.) on the right. 
 

 
 
Step 2: Add a Widget to Your Site 
Find the widget you want (e.g., "Search"). 
Drag and drop it into a widget area (e.g., "Sidebar"). 
 Customize the widget settings (if applicable). 
 Click Save. 
 
Alternative Method: 
 Click on a widget, select a widget area, and click Add Widget. 
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Blogging: 
Blogging deals with the regular sharing of information in the form of blogs on the 
internet. Understanding the blog concept is essential to get an insight into 
blogging. 
 

Who is a blogger? 
A blogger is a person who owns, runs, or maintains a blog. That is, posting 
articles or new posts, information, and sharing the most up-to-date news, 
opinions, and case studies. 
 
Difference Between Pages and Posts in WordPress 
In WordPress, Pages and Posts are the two main types of content. While they 
may look similar, they serve different purposes. 
Use Pages For: 
Permanent Content – About Us, Services, Contact, Privacy Policy. 
E-commerce Store Pages – Product descriptions, checkout pages. 
Use Posts For: 
Blogging – Articles, tutorials, case studies. 
News Updates – Latest announcements, press releases. 

Service oriented blogging website: 
 

Blogging for a service-oriented website can be an excellent way to engage with 
your audience. 
 
Step 1 - Select blog theme 
Go to Appearance > Themes, click Add New, and search for a "Blog" theme. 
Choose one that fits your style, click Install, and then Activate it. 
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Step 2 - Create your blog post 

●​ In your WordPress dashboard, Go to Posts > Add New. 
●​ Enter a post title like “My First Blog Adventure!” 
●​ Write your content in the Block editor, you can add text, images, 

videos, and other media. WordPress has a block editor, so you can 
easily add and customize different types of content like paragraphs, 
headings, images, quotes, and more. 

●​ Scroll down the page and look for the Featured Image section on the 
right side  

●​ Click Set Featured Image to upload or select an image 
●​ Add Categories : create a new category, click + Add New Category 

under the list of categories. Enter a name for your new category (e.g., 
"Web Design Tips" or "Client Success Stories") and click Add New 
Category. 
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Step 3 - Publish Your Post: 
Once you're happy with the content, click Publish. 
Confirm by clicking Publish again. 
 

How to connect all posts to page : 
Customize -> homepage settings -> select a static page -> Homepage (Example 
: home) ->posts page (Example : Blogs) 
 

Fulfledged Blogging website: 
 Remove all pages, and also go to homepage settings and select latest posts. 
Click Save Changes. 
Create Categories & Publish Your  Post 

1.​Go to Posts > Categories and create blog categories. 
2.​Navigate to Posts > Add New. 
3.​Write your blog post: 

●​ Add a post title. 
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●​ Write engaging content with headings,paragraphs, quotes, and more. 
●​ Insert images using “Add Media”. 
●​ Click Publish. 

 

Elementor: 
Elementor is one of the plugin. we can build pages and build websites using 
elementor.Elementor is one of the best page builders for WordPress. 
Elementor is a powerful drag-and-drop page builder for WordPress that allows 
users to design stunning websites without coding. Whether you're a beginner or 
an advanced user, Elementor makes website building easy with its real-time 
visual editor and customizable widgets. 

Elementor as a Page Builder: 
Elementor helps you design beautiful, responsive pages by providing a live 
editor where you can drag elements (text, images, buttons, etc.) and customize 
them instantly. 
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How to Install Elementor? 
In WordPress, go to Plugins > Add New. 
Search for "Elementor". 
Click Install > Activate. 
 

 
 
 

 
How to Use Elementor? 
Go to Pages > Add New. 
Click “Edit with Elementor”. 
Drag and drop widgets (Text, Images, Buttons, etc.). 
Customize styles, colors, fonts, and layout. 
Click Publish when done. 
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Elementskit: 
ElementsKit is an addon plugin for Elementor that enhances its functionality by 
providing extra widgets, modules, templates, and layout options. It allows 
you to create more advanced and professional websites without needing extra 
plugins or custom coding. 
 
How to Install ElementsKit? 
Step 1: Install the Plugin 
Log in to your WordPress Dashboard. 
Go to Plugins > Add New. 
Search for "ElementsKit". 
Click Install Now > Activate. 
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How to Use Pre-Built Templates & Sections: 
ElementsKit provides ready-made sections and templates to save design time. 
How to Insert Pre-Made Sections: 

Open a page in Edit with Elementor mode. 

Click the ElementsKit icon inside the editor. 

Browse 100+ pre-made designs. 

Click Insert and customize the content as needed. 

37 



 

 
 

Elementor as a Website Builder with Astra theme: 
Astra is a fast, lightweight, and customizable WordPress theme, perfect for 
use with Elementor. It also comes with Starter Templates, which allow you to 
create a beautiful website in minutes. 
 
Step 1: Install Elementor Plugin 
Go to Plugins > Add New. 
Search for "Elementor". 
Click Install Now > Activate. 
 
Step 2: Install Astra Theme 
In WordPress, go to Appearance > Themes > Add New. 
Search for "Astra" and click Install > Activate. 
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Step 3: Install the Starter Templates Plugin 

1.​Go to Plugins > Add New. 
2.​Search for "Starter Templates". 
3.​Click Install Now > Activate. 
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Step 4: Import a Starter Template 

1.​Go to Appearance > Starter Templates. 
2.​Select a page builder (Choose Elementor). 

 

 

 

3.​Browse and select a template (e.g., Business, Portfolio, eCommerce). 
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4.​Click on the template and preview the design. 

 
 
Click Import Complete Site (or choose Import Single Page). 
Wait for the import to finish (this may take a few minutes). 
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Step 5: Customize the Imported Template 

1.​Go to Pages > Edit with Elementor to modify content. 
2.​Change text, images, and colors using the Elementor editor. 
3.​Edit menu and logo under Appearance > Customize. 
4.​Click Update to save changes. 

 

Elementor Header & Footer Builder plugin: 

The Elementor Header & Footer Builder plugin  is a practical tool designed to 
help you build custom headers and footers for your WordPress website using the 
Elementor page builder 
 
Install the Plugin: 

●​ First, you need to install the Elementor Header & Footer Builder plugin.  
●​ Go to your WordPress dashboard > Plugins > Add New, then search for 

“Elementor Header & Footer Builder.” 
●​ Install and activate the plugin. 
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Create a New Header/Footer 

●​ After activating the plugin, you’ll see a new menu item under Appearance 
called Header Footer & Blocks. 

●​ Click on it, and you’ll see an option to Add New. You can choose to create 
a Header or Footer. 

●​ You'll be asked to give it a name and specify if it's for the Header, Footer, 
or a custom block. For example, you could create a "Custom Footer." 

Design with Elementor 

●​ Once you've created a header or footer, it’ll show up in your Elementor 
interface. 

●​ Click the Edit with Elementor button, and you can start designing your 
header or footer using Elementor widgets. 

●​ You can add elements like logos, navigation menus, social media icons, 
contact info, and more. 

●​ You also have full control over styling, alignment, and layout. 

Go to Header Footer & Blocks > Add New > Footer. 
Give it a name (e.g., “Custom Footer”). 
Click on Edit with Elementor. 
Design the footer using Elementor widgets: drag and drop the Icon List widget 
for social media links, the Text Editor widget for contact details, and the Nav 
Menu widget for navigation links. 
Once you're done, set the display conditions to ensure this footer appears 
site-wide. 
Publish it. 
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Clone plugin: 
The Clone Pages plugin is a WordPress plugin that allows you to duplicate or 
clone pages and posts on your website. This is particularly useful if you want to 
create a new page with the same layout and content as an existing one, saving 
you time and effort compared to starting from scratch. 
Here's how to use it practically: 

Install the Plugin 

●​ Go to your WordPress dashboard. 
●​ Navigate to Plugins > Add New. 
●​ Search for Clone Page 
●​ Click Install Now and then activate the plugin. 

 

Clone a Page or Post 

●​ Once the plugin is activated, go to Pages or Posts (depending on what you 
want to clone). 

●​ You'll see a new Clone link next to each page or post listed. 
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●​ Click the Clone link for the page or post you want to duplicate. 

Edit the Cloned Page 

●​ After clicking Clone, a new draft of the page or post will be created. 
●​ This draft will have all the same content, layout, and settings as the original, 

but it will be in a "Draft" status, so it won’t be published immediately. 
●​ You can now open the draft and make any necessary changes. For 

example, you can update the title, edit the content, or change the layout to 
fit the new page's needs. 

Publish the Cloned Page 

●​ Once you're satisfied with the changes, you can publish the cloned page as 
you would with any other page on WordPress. 

 

Ecommerce website: 

In eCommerce website in WordPress is a website built using WordPress that 
allows businesses to sell products or services online. These websites typically 
have an integrated shopping cart system, payment gateways, product catalog, 
and other essential eCommerce functionalities that facilitate online transactions. 

In WordPress, WooCommerce is the most popular plugin used to transform a 
regular WordPress site into a fully functional eCommerce store. It allows you to 
sell both physical and digital products, manage inventory, handle payments, and 
track orders with ease. 

Steps to Create an eCommerce Website in WordPress: 

Here’s a practical step-by-step guide to building an eCommerce website using 
WooCommerce in WordPress. 

Install the WooCommerce Plugin: 

Install WooCommerce: From your WordPress dashboard, go to Plugins > Add 
New. Search for WooCommerce and click Install Now, then activate the plugin. 
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WooCommerce Setup Wizard: After activation, WooCommerce will guide you 
through a setup wizard. The setup wizard helps you configure essential settings, 
such as: 

●​ Store Location: The country where your store is based. 
●​ Currency: The currency your products will be sold in. 
●​ Payment Methods: Choose payment gateways such as PayPal, Stripe, or 

credit card payments. 
●​ Shipping: Set up shipping zones, methods, and rates. 
●​ Tax Settings: Configure tax rules based on your location. 

Choose a Theme: 

●​ Select a WooCommerce-Compatible Theme: Choose a theme that works 
well with WooCommerce. Many WordPress themes are specifically 
designed to integrate seamlessly with WooCommerce and provide a 
beautiful shopping experience. 

Popular themes for WooCommerce include Storefront (the official 
WooCommerce theme) and Astra, OceanWP, or Flatsome. 
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●​ Customize the Theme: You can customize the theme through the 
WordPress Customizer (found under Appearance > Customize), where 
you can adjust things like: 

Logo and brand colors 

Font style and size 

Page layouts (for product pages, checkout page, etc.) 

 

Add Products to Your Store: 

add a product, go to Products > Add New. 

In eCommerce, there are several types of products you can sell, each with 
different characteristics and features. They are: 

●​ Simple products 
●​ Variable products 
●​ Grouped products 
●​ Affiliate products 

Simple Product: 

A Simple Product in WooCommerce refers to a straightforward product type that 
doesn’t have variations (like size or color options) and is typically used for single 
items. For example, a single-size t-shirt, a book, or a mug. 

  

 

Navigate to the Products Section: 

In the WordPress dashboard, go to Products > Add New. This will open the 
page where you can add a new product. 
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 Enter Product Title and Description: 

Product Title: Enter the name of your product. For example, “Organic Soy 
Candle.” 

Product Description: This is the long description of the product that will appear on 
the product page. Here, you can include detailed information about the product 
such as features, benefits, ingredients, usage instructions, etc. 

 

 Product Data Section: 

Product Type: The default type is "Simple product." WooCommerce gives you 
several types of products (Simple, Variable, Grouped, etc.), but for this example, 
we’ll leave it as Simple product. 

General: In this tab, you’ll set the pricing. 

●​ Regular Price: Enter the regular price of the product. For example, 
“$15.00.” 

●​ Sale Price (optional): If you’re offering a discount, you can add a sale price 
here. For example, “$12.00.” 
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Inventory: 

●​ If you want to manage stock, tick the Manage stock? checkbox. 
●​ SKU: Enter a unique SKU (Stock Keeping Unit) for your product. This helps 

you track the product in your inventory. 
●​ Stock Status: Set the stock status as In Stock (or Out of Stock, depending 

on availability). 
●​ Allow backorders?: You can enable or disable backorders if the product is 

out of stock but you want to allow orders. 

Shipping: 

●​ Weight: If you’re selling a physical product, you may want to enter the 
weight for shipping calculations. 

●​ Dimensions: Add the dimensions (length, width, height) if relevant. 
●​ Shipping Class: You can assign a shipping class (e.g., “small,” “large,” 

“free shipping”) to help calculate shipping rates more accurately 

Linked Products (optional): 

●​ Upsells: Here, you can recommend higher-priced items. 
●​ Cross-sells: Suggest related products that can be added to the cart. 

Product Short Description: 

This is the brief product summary that appears next to the product image on the 
product page 

Product Images: 

Product Image: On the right-hand side, you’ll see an option to set the Product 
Image. This is the main image that will appear on your product page. Upload a 
high-quality image of the product. 

Product Gallery: Below the main image, you can also add multiple images for a 
gallery. 

Product Categories and Tags 
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●​ Categories: You can assign this product to a specific category (e.g., 
“Candles,” “Home Decor”). If you don’t have a category yet, you can create 
one. 

●​ Tags: Tags help with SEO and filtering. For example, you might add “soy 
candle,” “lavender,” or “handmade.” 

Publish the Product: 

Once you’ve filled in all the necessary fields, Publish to make the product live on 
your store. 

 

Variable Product: 

A Variable Product in WooCommerce is a type of product that has multiple 
variations (e.g., size, color, style) with different prices, stock levels, and attributes. 
This is ideal for products that come in various options, such as clothing, shoes, or 
electronic gadgets. 

Create a New Product 

1.​In your WordPress dashboard, go to Products > Add New. 
2.​This will open the page where you can add your new product 
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Enter the Product Title and Description 

Choose "Variable Product" Type 

●​ Scroll down to the Product Data section (below the product description). 
●​ In the Product Type dropdown, select Variable product.​

By default, WooCommerce sets the product type to Simple Product. For 
variable products, you need to change this to Variable product so that you 
can set different variations (e.g., size, color). 

Add Product Attributes 

Attributes are what make your product variable. For example, size, color, or 
material. 

●​ Go to the “Attributes” tab under the Product Data section. 
●​ Click Add to create a new attribute (e.g., Size, Color). 
●​ For Size: 

Add a name: Size. 

Under Value(s), input the different sizes your product is available in (e.g., 
Small, Medium, Large, Extra Large). Separate each option with a vertical 
bar (|), like this: Small | Medium | Large | XL. 
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●​ For Color: 

Add a name: Color. 

Under Value(s), input the different colors your product is available in (e.g., 
Red, Blue, Green). Again, separate each option with a vertical bar: Red | 
Blue | Green. 

●​ Enable “Used for variations”: For each attribute, check the box that says 
Used for variations. This tells WooCommerce that you want to create 
variations based on these attributes. 

 

Create Variations 

Once you’ve added your attributes, the next step is to create the variations. 

●​ Go to the “Variations” tab under Product Data. 
●​ Click the dropdown for Add variation and select Create variations from 

all attributes. 

WooCommerce will automatically create all possible combinations of your 
attributes. For example, if you have 3 sizes and 3 colors, WooCommerce 
will create 9 variations (e.g., Small-Red, Medium-Blue, Large-Green, etc.). 

●​ Click Go to create these variations. 
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Set Prices, Stock, and Other Information for Each Variation 

Now, you need to define specific details for each variation, such as price, stock 
status, image, SKU, etc. 

●​ Price: For each variation, you can set a different price. For example: 

Red-Small might cost $20. 

Blue-Medium might cost $22. 

●​ Stock: You can manage stock for each variation individually. You may 
enable the Manage stock? checkbox to track stock levels for each 
variation. 

For example, you may have 10 units of Red-Small and 5 units of 
Blue-Medium. 

●​ SKU: You can assign a unique SKU to each variation (optional but 
recommended for inventory management). 

●​ Image: You can add a unique image for each variation. For example: 

The Red-Small variant could have an image of a small red shirt. 

The Blue-Medium variant could have an image of a medium blue shirt. 

●​ Weight, Dimensions, and Shipping: If needed, you can assign different 
weight or dimensions for each variation (useful if your product sizes differ 
significantly). 

Save the Variations 

After you’ve filled out all the information for each variation (e.g., price, stock, 
image, etc.), click Save Changes. 

Add Product Images 

Set Product Categories and Tags 

Publish the Product 
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Once you’re done configuring your product, click Publish to make it live on your 
store. 

 

 

Swatches plugin: 

The Swatches for WooCommerce plugin  is a useful tool for enhancing the user 
experience on WooCommerce stores that sell variable products (such as 
clothing, accessories, and other products that come in different colors, sizes, 
materials, etc.). This plugin allows you to replace the standard dropdown menus 
for product variations (like size, color, or material) with more visually appealing 
and user-friendly swatches. 

step-by-step guide on how to use the "Swatches for WooCommerce" plugin: 

Install the Plugin 

1.​Go to your WordPress Dashboard. 
2.​Navigate to Plugins > Add New. 
3.​In the search bar, type “Swatches for WooCommerce”. 
4.​Find the plugin by Emran Ahmed and click Install Now. 
5.​After installation, click Activate to activate the plugin. 
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Create Product Attributes 

●​ Before you can use swatches, you need to have product attributes that 
are used for variations, like Color or Size. 

●​ Go to Products > Attributes in your WooCommerce dashboard. 
●​ Add an attribute (e.g., Color): 

Name: Color 

Slug: color 

Choose Type: Select Color if you want to use color swatches. 

●​ Add the terms for this attribute (e.g., Red, Blue, Green). 

Set Up Variable Product 

You need a variable product to see how swatches work. For example, if you’re 
selling a t-shirt that comes in different colors and sizes, you’ll need to create a 
variable product. 

●​ Go to Products > Add New and create a new product (e.g., “Men’s 
T-shirt”). 

●​ In the Product Data section, change the product type to Variable Product. 
●​ Go to the "Attributes" tab and add the attributes you created earlier (e.g., 

Color, Size). 
●​ Under the Variations tab, create the variations for each combination (e.g., 

Red-Small, Blue-Medium). 

Assign Swatches to Attributes 

Now, assign swatches to the attributes you created (e.g., Color): 

●​ Go back to Products > Attributes. 
●​ For the Color attribute, click the Configure Terms button to manage the 

color options. 
●​ For each color (e.g., Red, Blue, Green), you can: 
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Upload an Image for the color (if you're using image swatches). 

Choose a Color (if you're using color swatches). You can select a specific 
hex color for each term (e.g., Red with hex code #FF0000). 

Display Swatches on Product Pages 

●​ When you create or edit a Variable Product, you’ll notice that the swatch 
options now appear in the variation settings. 

●​ In the Product Data > Variations tab, each variation will now have a 
swatch option (e.g., color swatches, image swatches, or labels). 

●​ Once you’ve assigned swatches to each variation, save the product. 
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Grouped product: 

A Grouped Product in WooCommerce is a type of product that allows you to 
group multiple individual products together for customers to purchase all or some 
of the items in the group. Each product in the group is still a separate product, 
but they are presented together in a bundle on the same product page. 

Grouped products are typically used when you have several related products, 
and you want to make it easier for customers to purchase them together. 

Step-by-Step Guide to Adding a Grouped Product 

Create Individual Products for the Group 

Before you can create a grouped product, you must first create the individual 
products that you want to include in the group. 

●​ Go to Products > Add New in your WordPress dashboard. 
●​ Create each product you want to include in the group. 
●​ Set each product to be a Simple Product (not variable), and enter the 

usual product information (title, description, price, image, etc.). 
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●​ Once you've added each product, publish them. These will now be 
available to add to the grouped product. 

 

 

Create the Grouped Product: 

Now, it’s time to create the Grouped Product that will showcase all the individual 
products together. 

●​ Go to Products > Add New again to create a new product. 
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●​ Enter the Grouped Product Title 
●​ Write a Product Description 

Set the Product Type to Grouped 

Scroll down to the Product Data section (below the description). 

In the Product Type dropdown, select Grouped product. 

Add Individual Products to the Group 

 

Now, you need to associate the individual products that make up the group. 

●​ Go to the "Linked Products" tab under the Product Data section. 
●​ In the Grouped Products field, begin typing the names of the individual 

products you created earlier (e.g., Lawn Mower, Lawn Fertilizer, Grass 
Seed). 

●​ Select the Products you want to include in the group. These will now be 
linked to the grouped product. 

Set the Product Image and Gallery 

Set Categories and Tags 

Publish the Product 
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Once you've completed all the necessary fields, click the Publish button to make 
the grouped product live on your website. 

 

Affiliate product: 

An affiliate product on an eCommerce website refers to products that you 
promote or sell on your site, but that are owned and fulfilled by another company. 
When a customer purchases through your affiliate link, you earn a commission. 
This model is often used in blogs, review sites, or niche eCommerce stores to 
monetize content without needing to stock products. 

Choose an Affiliate Program 

●​ You’ll first need to partner with an affiliate program. Some popular ones 
include: 

Amazon Associates (Amazon) 

ShareASale 

After joining, you’ll get affiliate links for products to promote. 

Adding Affiliate Products to Your Site 
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There are two main ways to add affiliate products: 

a. Manually Adding Affiliate Products: 

●​ Go to your WordPress dashboard. 
●​ Posts > Add New (for blog posts) or Pages > Add New (for pages), or 

Products > Add New if you’re using WooCommerce. 
●​ Add content related to the product (description, benefits, etc.). 
●​ Embed the affiliate link where relevant, or if using WooCommerce, enter the 

affiliate URL in the product’s external/affiliate product section. 

 

b. Using WooCommerce: 

●​ Install WooCommerce plugin if you haven’t already. 
●​ Go to Products > Add New and enter the product details like name, 

description, and price. 
●​ Under the “Product Data” section, select External/Affiliate Product. 
●​ Add the affiliate URL in the “Product URL” field. 
●​ Optionally, set a button text like “Buy Now” or “Check Price”. 
●​ This way, users click on the affiliate link and are taken directly to the product 

page on the merchant’s site. 
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Coupons: 

Coupons in WooCommerce allow store owners to offer discounts, promotions, 
and deals to customers. These coupons can be configured with various rules and 
restrictions, such as minimum purchase amounts, product-specific discounts, and 
expiration dates. 
How to Create a Coupon in WooCommerce (Step-by-Step) 

Step 1: Enable Coupons in WooCommerce 

●​ Log in to your WordPress dashboard. 
●​ Navigate to WooCommerce > Settings. 
●​ Click on the General tab. 
●​ Scroll down to the Enable Coupons section and ensure that "Enable the use 

of coupon codes" is checked. 
●​ Save changes. 

Create a Coupon 

1.​Go to Marketing > Coupons (in older versions, it may be under 
WooCommerce > Coupons). 

2.​Click Add Coupon. 
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3.​Enter a Coupon Code (e.g., "SUMMER10"). 
4.​Add a Description (optional) for internal reference. 

 

Configure Coupon Settings 

A. General Settings 

●​ Discount Type: 

Percentage Discount –  This discount applies a percentage off the total 
cart value. e.g., 10% off. 

Fixed Cart Discount – This discount applies to the total cart value, 
regardless of the products in the cart. e.g., $20 off the total cart value. 

Fixed Product Discount – This discount applies only to specific products. 
e.g., $5 off specific products. 

●​ Coupon Amount – Enter the discount amount (e.g., 10 for 10% or $10). 
●​ Allow Free Shipping – Optionally, check this to enable free shipping when 

the coupon is applied. 
●​ Coupon Expiry Date – Set an expiration date for the coupon. 
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Usage Restriction 

●​ Minimum Spend – Set a minimum cart value required to use the coupon. 
●​ Maximum Spend – Set a maximum cart value for coupon applicability. 
●​ Individual Use Only – Prevents this coupon from being used with other 

coupons. 
●​ Exclude Sale Items – Disallows applying the coupon to already discounted 

products. 
●​ Products & Categories – Choose specific products or categories for the 

coupon. 
●​ Exclude Products & Categories – Select items/categories that the coupon 

will not apply to. 

 

C. Usage Limits 

●​ Usage Limit Per Coupon – Limit the number of times this coupon can be 
used in total. 

●​ Usage Limit Per User – Restrict how many times a customer can use the 
coupon. 
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Step 4: Publish and Share 

●​ Click Publish to activate the coupon. 
●​ Share the coupon code via email, social media, or display it on your 

website. 

 

Convertful Plugin: Displaying Coupons on a WooCommerce Website 

Convertful is a powerful lead generation and conversion optimization plugin for 
WordPress that allows you to create popups, floating bars, slide-ins, and 
embedded forms to display discount coupons and special offers on your 
WooCommerce store. 

Step-by-Step Guide to Display Coupons Using Convertful 

Step 1: Install and Activate Convertful Plugin 

●​ Log in to your WordPress dashboard. 
●​ Go to Plugins > Add New. 
●​ Search for Convertful and click Install Now. 
●​ After installation, click Activate. 
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Step 2: Connect Convertful to Your Website 

●​ Go to Convertful > Settings in your WordPress dashboard. 
●​ Click on Sign Up or Log In to create/connect your Convertful account. 
●​ After logging in, follow the on-screen steps to connect your 

WooCommerce website. 
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Step 3: Create a Coupon Popup in Convertful 

A. Select a Widget Type 

●​ Go to Convertful Dashboard. 
●​ Click Create Widget and choose a design format, such as: 

Popup (Best for attracting attention) 

Floating Bar (Ideal for showing at the top/bottom of the page) 

Slide-in (Appears from the side for a subtle approach) 

 

B. Customize the Coupon Display 

●​ Select a pre-built template or start from scratch. 
●​ Add a headline (e.g., "Get 10% Off Your First Order!"). 
●​ Include a coupon code (e.g., "WELCOME10"). 
●​ Customize colors, fonts, and images to match your brand. 

C. Set Display Rules 

●​ Show the popup when a user visits a specific page (e.g., cart or checkout 
page). 

●​ Trigger it when a user is about to leave (exit-intent popup). 
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●​ Display it only for new visitors or logged-in users. 

 

Step 4: Publish and Test the Coupon Widget 

1.​Click Save & Publish in Convertful. 
2.​Visit your WooCommerce store and check if the coupon popup appears as 

expected. 
3.​Test by applying the coupon at checkout to ensure it works. 
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Shipping: 

Shipping is a crucial part of any WooCommerce store, allowing store owners to 
set up delivery options, rates, and rules based on location, weight, and more. 
WooCommerce provides flexible shipping settings to manage domestic and 
international shipping efficiently. 
Step 1: Enable Shipping in WooCommerce 

1.​Log in to your WordPress dashboard. 
2.​Go to WooCommerce > Settings. 
3.​Click on the Shipping tab. 
4.​If shipping is not enabled, check if your store location is set under 

WooCommerce > Settings > General. 

 

Step 2: Create Shipping Zones 

A Shipping Zone is a geographical area where you set shipping methods and 
rates. 

Example: 

●​ Zone 1: USA (Free Shipping) 
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●​ Zone 2: Europe (Flat Rate Shipping) 
●​ Zone 3: Rest of the World (Weight-Based Shipping) 

How to Add a Shipping Zone 

1.​Go to WooCommerce > Settings > Shipping. 
2.​Click Add Shipping Zone. 
3.​Enter the Zone Name (e.g., USA, Europe). 
4.​Select the Zone Region (e.g., United States). 
5.​Click Add Shipping Method to define how customers will be charged. 
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Step 3: Configure Shipping Methods 

WooCommerce offers three built-in shipping methods: 

1. Free Shipping. 

●​ Example: "Free shipping on orders above $100" 
●​ How to Set Up: 

1.​Select Free Shipping under the shipping zone. 
2.​Set conditions like minimum order amount or coupon-based free 

shipping. 
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2. Flat Rate Shipping. 

●​ Example: "Charge $10 per order for shipping" 
●​ How to Set Up: 

1.​Select Flat Rate under the shipping zone. 
2.​Enter the shipping cost (e.g., $10 per order). 
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Payment Gateways in WooCommerceUPI: 

WooCommerce supports 100+ payment gateways globally, allowing businesses 
to accept payments via credit/debit cards, UPI, net banking, wallets, and 
cryptocurrencies. The number of available gateways depends on your country 
and business needs. 

UPI: 

A UPI (Unified Payments Interface) plugin in WooCommerce allows store 
owners to accept direct UPI payments from customers during checkout. 

The Knit Pay UPI Plugin is a WordPress extension designed to integrate Unified 
Payments Interface (UPI) payment capabilities into your WooCommerce store. 
This integration allows customers to make direct and instant payments using UPI 
apps such as BHIM, Google Pay,  Paytm, PhonePe, or any banking UPI 
application. 

What Does a UPI Plugin Do? 
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●​ Enables direct payments using UPI apps like Google Pay, PhonePe, 
Paytm, BHIM, and WhatsApp Pay. 

●​ Generates a QR Code at checkout for easy payments. 
●​ Allows customers to enter a UPI ID and pay directly. 
●​ Provides instant money settlement without delays. 

Installation: 

●​ Navigate to your WordPress dashboard. 
●​ Go to Plugins > Add New. 
●​ Search for "Knit Pay UPI" and click Install Now. 
●​ After installation, click Activate. 

 

Configure UPI Payment Settings 

1.​Go to WooCommerce > Settings > Payments. 
2.​Find UPI Payment Gateway and click Manage. 
3.​Enable the payment method and enter your UPI ID (e.g., yourname@upi). 
4.​Choose QR Code Display (optional) and configure instructions. 
5.​Click Save Changes. 
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How to add a "without GST QR code" to your WordPress website: 

1. Choose a QR code plugin: 

Install a WordPress plugin like "QR Code Generator" or "Kaya QR Code 
Generator" from the plugin repository.  

2. Generate the QR code: 

Access the plugin settings and input the URL you want the QR code to link to 
(e.g., your contact page).  

3. Embed on your page: 

Copy the generated shortcode and paste it into the desired location on your 
website where you want the QR code to appear.  

Important considerations: 

Compliance for GST businesses: 

If you are a business required to generate GST compliant invoices, you will need 
a separate solution to create QR codes that include all the necessary GST 
details.  

UPI payment integration: 

If you want to enable UPI payments through QR codes, specific plugins designed 
for UPI integration are available and can be used instead. 

 

Razorpay: 

Razorpay is a popular payment gateway that allows businesses to accept online 
payments in India. You can integrate Razorpay into your WordPress e-commerce 
site using plugins like WooCommerce Razorpay Payment Gateway. 

Install & Activate the Plugin 
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1.​Login to your WordPress dashboard. 
2.​Navigate to Plugins > Add New. 
3.​Search for "WooCommerce Razorpay". 
4.​Click Install Now and then Activate the plugin 

 

Get Razorpay API Credentials 

1.​Sign up or log in to your Razorpay account: Razorpay Dashboard 
2.​Go to Settings > API Keys. 
3.​Click Generate Live Key (for real transactions) or Generate Test Key (for 

testing). 
4.​Copy the Key ID and Key Secret. 

Configure Razorpay in WooCommerce 

1.​Go to WooCommerce > Settings > Payments. 
2.​Find Razorpay in the payment options and click Manage. 
3.​Enable Razorpay Payment Gateway. 
4.​Paste the Key ID and Key Secret from Razorpay. 
5.​Enable Test Mode if you want to test transactions before going live. 
6.​Click Save Changes. 
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 Go Live 

1.​Disable Test Mode in WooCommerce Razorpay settings. 
2.​Use Live API Keys from your Razorpay dashboard. 
3.​Test with real transactions. 
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SEO (SEARCH ENGINE OPTIMIZATION) 

What is SEO? 
The process of ranking our websites on the top of the search engines like 
Google, Bing, and Yahoo to attract more organic (unpaid) traffic. It involves 
optimizing content, technical aspects, and backlinks to rank higher in search 
results.  
 

What is SERP? 

SERP stands for Search Engine Results Page. It is the page you see after 
entering a query into a search engine like Google. The SERP displays a list of 
results that match your search, which can include websites, images, videos, 
maps, ads, and more. 

SERP LAYOUT 

| 

Top 4 Ads 

| 

10 Organic results 

| 

Bottom 3 Ads 
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How Search Engines Work: 
Crawling                        -  Collection of data 
Indexing                        -  Categorisation of data 
Calculating Relavancy  - Ranking Factors 
Retrieving results          - Displaying results on serp 
 

 
 
Crawling: 
Crawling is the process where search engines send out bots, also known as 
"web crawlers" or "spiders," to discover new and updated content across the 
web.The crawler visits web pages, reads the content, and follows links to other 
pages.It scans text, images, videos, PDFs, and more. 
Example: Like a librarian checking every new book in the library to see what it’s 
about. 
 
Indexing: 
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Indexing is the process of storing and organizing the content found during 
crawling. This “index” is like a giant library database where every page is 
cataloged.The search engine analyzes the content, keywords, metadata, images, 
and structure of the page. 
Pages are stored in Google's massive index, ready to be retrieved when 
someone searches for related information. 
Example: A librarian filing books in specific categories so they can be easily 
found later. 
 
Calculating Relevance: 
When a user types a query, the search engine analyzes its index to find the most 
relevant results.Google uses complex algorithms to determine relevance based 
on hundreds of ranking factors like keywords, backlinks, page speed, 
mobile-friendliness, and user engagement. 
Example: A librarian recommending the best book based on what the reader is 
looking for. 
 
Retrieving Results: 
The final step is delivering the search results on the Search Engine Results Page 
(SERP).Google ranks the relevant pages based on their quality and relevance 
score.The results may include organic listings, ads, featured snippets, images, 
and more. 
Example: The librarian hands over a stack of books sorted from most to least 
relevant. 
 
Keyword Research Techniques : 
Keyword research is the process of finding and analyzing words or queries that 
people use when searching for information. 
 
Brainstorming - Think about your business, products, services, or the topic 
you’re targeting. 
Google suggest - Google Suggest is the dropdown list that appears when you 
start typing in the Google search bar 
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Ubersuggest - Ubersuggest is a free keyword research tool created by Neil 
Patel. It helps generate keyword ideas and provides SEO metrics. 

 

What are SEO Techniques? 
SEO (Search Engine Optimization) involves various techniques to improve a 
website's ranking on Google, Bing, and other search engines. By using the 
right SEO techniques, you can attract organic (free) traffic and grow your 
website’s visibility. 
 

1.​White Hat SEO(ONPAGE SEO,OFF PAGE SEO,TECHNICAL SEO) – 
Ethical and Google-approved techniques 

2.​Black Hat SEO – Unethical, rule-breaking techniques for quick results. 
3.​Grey Hat SEO – A mix of both White Hat and Black Hat strategies. 

 

Black Hat SEO (Unethical & Risky Techniques): 
Black Hat SEO involves manipulative techniques to rank quickly in search 
engines. These methods violate Google's guidelines and can lead to penalties 
or website deindexing. 
 
Common Black Hat SEO Techniques: 
Keyword Stuffing – Repeating keywords unnaturally in content to manipulate 
rankings. 
Hidden Text & Links – Placing invisible keywords or links to trick search 
engines. 
Automated Content (AI Spam) – Generating low-quality, AI-written content 
without real value. 
Changing the text background color. 
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Grey Hat SEO (Borderline Techniques – Risky but Not Illegal) : 
Grey Hat SEO is a mix of White Hat and Black Hat techniques. It is not 
explicitly banned by search engines but can be risky if overused. 

 
Common Grey Hat SEO Techniques: 
Cloaking – Showing different content to search engines and users. 
Duplicate Content – Copying content from other websites. 
Spammy Backlinks – Buying backlinks from low-quality, irrelevant sites 
Fake Social Signals – Buying fake Facebook likes, Twitter followers, or YouTube 
views. 
 

White Hat SEO (Ethical & Safe Techniques): 
White Hat SEO refers to legitimate, Google-approved techniques that follow 
search engine guidelines. It focuses on long-term website growth. 
 
Key White Hat SEO Techniques: 
 Quality Content – Write valuable, unique, and informative content. 
 Keyword Optimization – Use keywords naturally without stuffing. 
 Mobile Optimization – Ensure your site is mobile-friendly. 
 Page Speed Optimization – Improve loading time for a better user experience. 
 Backlink Building (Ethical Methods) – Get links from reputable websites. 
 Internal Linking – Connect related pages within your website. 
 

Google updates: 
Google Updates refer to the changes or modifications made to Google’s search 
algorithms and systems to improve the quality, relevance, and accuracy of search 
results. These updates help ensure that users get the most useful and 
trustworthy information when they search on Google. 
 

1. Google Panda Update (2011) 
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●​ Purpose: To target low-quality content and improve rankings for 
high-quality websites. 

●​ Focus: Thin content, duplicate content, content farms, keyword stuffing, 
and poor user experience. 

●​ Impact: Websites with valuable, original, and informative content saw 
better rankings, while sites with low-quality content were penalized. 

2. Google Penguin Update (2012) 

●​ Purpose: To fight web spam, specifically targeting manipulative 
link-building practices. 

●​ Focus: Over-optimized anchor text, link schemes, unnatural backlinks, and 
black-hat SEO techniques. 

●​ Impact: Sites using spammy link-building strategies were penalized, while 
those with natural, high-quality backlinks benefited. 

3. Google Pigeon Update (2014) 

●​ Purpose: To improve local search results by enhancing Google’s location 
and distance ranking parameters. 

●​ Focus: Local SEO, Google Maps integration, and proximity-based 
searches. 

●​ Impact: Boosted the visibility of local businesses in search results, aligning 
local search more closely with traditional web ranking factors. 

4. Exact Match Domain (EMD) Update (2012) 

●​ Purpose: To reduce the influence of exact-match domains that ranked 
highly despite having low-quality content. 

●​ Focus: Domains that matched search queries exactly (e.g., 
"cheapflights.com") but offered poor content. 

●​ Impact: Only affected low-quality EMDs; high-quality sites with exact-match 
domains remained unaffected. 

5. Google Hummingbird Update (2013) 
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●​ Purpose: A complete overhaul of Google’s core algorithm to better 
understand the intent behind search queries. 

●​ Focus: Semantic search, natural language processing, and conversational 
queries. 

●​ Impact: Improved Google’s ability to deliver relevant results for complex 
queries, emphasizing meaning over exact keywords 

 

6. Mobilegaddon Update (2015) 

●​ Purpose: To prioritize mobile-friendly websites in mobile search results. 
●​ Focus: Mobile usability, responsive design, and page load speed on mobile 

devices. 
●​ Impact: Sites that weren’t mobile-optimized saw a drop in mobile search 

rankings, encouraging widespread adoption of responsive web design. 

What is On-Page SEO? 
On-page SEO refers to optimizing individual web pages to improve rankings 
on search engines like Google. It involves optimizing content, HTML elements, 
and website structure to make it more search engine and user-friendly. 

Install an SEO Plugin 

A good SEO plugin helps you optimize pages easily. The best options are: 

●​ All in One SEO (AIOSEO) 
●​ Yoast 
●​ Rank Math 

All in one SEO plugin: 

The All in One SEO (AIOSEO) plugin is one of the best SEO tools for 
WordPress. It helps optimize your website for search engines, improve rankings, 
and drive more traffic 

 Install and Activate AIOSEO Plugin: 
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●​ Log in to your WordPress Dashboard. 
●​ Go to Plugins → Add New. 
●​ Search for All in One SEO. 
●​ Click Install Now and then Activate. 

 

Optimize Blog Posts & Pages for SEO: 

To optimize a post or page for SEO, follow these steps: 

 Open AIOSEO Settings in Your Post/Page 

Go to Posts → Add New (or Edit an existing post). 

Scroll down to AIOSEO Settings below the content editor. 

●​ Optimize Focus Keyphrase (Keyword Optimization) 
●​ Optimize URL (Permalink Structure) 
●​ Use Proper Headings (H1, H2, H3 Structure) 
●​ Add Internal & External Links 
●​ Optimize Images (Alt Text ) 
●​ Bolds & Italics 
●​ First line of paragraph 
●​ Enable Schema Markup (Rich Snippets) 
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What exactly google collects from our website: 
When Google crawls your website, it looks at various parameters to understand 
the content and how to rank it in search results. The parameters you mentioned 
are important for SEO and indexing. Here’s a breakdown of what each parameter 
means and how Google uses them: 
Focus Keyphrase: 
A focus keyphrase (or focus keyword) is the main term or phrase that you want a 
specific webpage to rank for in search engine results. It is the primary keyword 
that best represents the topic of your content and aligns with the search intent of 
your target audience. 

 
 

Title:  

This is the page title.Google uses the title to understand the main topic of the 
page. It's one of the most important SEO factors, so it should accurately describe 
the content while including relevant keywords. 
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Description: 
oogle may show this description in the search results snippet. While it doesn't 
directly impact rankings, a well-written, keyword-rich description can improve the 
click-through rate (CTR) to your site. The description should be concise and 
summarize the content. 
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Headings (H1, H2, H3, etc.): 
Google looks at headings to understand the content structure. The <h1> tag is 
used to identify the main topic of the page. Subheadings (H2, H3) help organize 
content into logical sections and make it easier for Google to understand what 
the page covers. 

 
 
Permalink (URL):    
The URL structure is typically visible as part of the page address (e.g., 
www.example.com/blog-post-title/). A clean, keyword-rich URL is easier 
for Google to crawl and understand. Google prefers URLs that are descriptive, 
short, and contain relevant keywords. 
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Bolds & Italics: 
Bold text often highlights important keywords or phrases, and italicized text can 
show emphasis. While it doesn’t directly impact SEO, using these formatting 
tools strategically can help make important content stand out to both users and 
search engines 
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Image Alt Text: 
Google can’t "see" images the way humans do, so it relies on the alt text to 
understand the content of an image. This is important for accessibility and SEO. 
Descriptive, keyword-rich alt text can help your images rank in image search and 
contribute to overall page relevance. 
 

 
Links (Internal): 
Internal links help Google discover and index new pages on your site. They also 
pass "link equity" from one page to another, which can help boost rankings. A 
good internal linking structure enhances site navigation and helps with SEO. 
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Links (External): 
 External links are seen as signals of trust and authority, especially if you’re 
linking to high-quality, authoritative sources. Google evaluates the relevance and 
quality of external links to understand how well-connected your content is with 
other trusted websites. 

 
 
First line of paragraph: 
Google doesn't specifically use the first line of a paragraph as a ranking factor, 
but it does help shape the context and relevance of the content. For users, it's 
important to grab their attention early with a clear, relevant introduction that 
aligns with the search intent.For SEO, the first line should ideally include the 
primary keyword or a variation of it, as it helps signal to both users and search 
engines what the content is about.   
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Keyword Density Formula: 
Keyword Density Formula in SEO refers to how often a specific keyword or 
phrase appears in the content compared to the total number of words. It is 
usually expressed as a percentage. 
 
Formula: 

Keyword Density (%) = Number of times you have repeated your focus    
keyphrase 

                                                  -----------------------------------------------------------*100  
                                                   Total no. of words  
 

Explanation: 

●​ Number of Occurrences of Keyword: This is the total number of times 
your target keyword (or key phrase) appears in your content. 

●​ Total Number of Words in the Content: This is the overall word count of 
the page or article. 

Example: 
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If your page has 500 words, and your target keyword appears 10 times, the 
keyword density would be: 

Keyword Density (%) = (10/500)×100 = 2% 

What Does Keyword Density Mean for SEO? 

●​ Too Low: If the keyword density is too low, Google might not clearly 
understand what your page is about, which could affect rankings. 

●​ Too High: If the keyword density is too high (commonly referred to as 
"keyword stuffing"), it could be seen as unnatural and lead to penalties or a 
poor user experience. 

Readability: 

Readability in SEO refers to how easily and comfortably users can read and 
understand the content on your website. It plays a significant role in user 
experience and, indirectly, in your rankings. Google values content that is 
accessible and easy to digest, which is why readability is a critical factor in SEO. 

Factors That Affect Readability in SEO: 

●​ Sentence Length 
●​ Paragraph Structure 
●​ Use of Simple Language 
●​ Grammarly 
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Google search console : 
Google Search Console (GSC) is a free tool provided by Google to help 
website owners, SEO professionals, and webmasters monitor, maintain, and 
improve their site's presence in Google Search results. It provides valuable 
insights into how Google crawls, indexes, and ranks your site, as well as details 
on potential issues that may affect SEO performance. 

Practical Steps to Use Google Search Console: 

Step 1: Sign in to Google Search Console 

●​ Go to Google Search Console. 
●​ Sign in with your Google account. 

Step 2: Add Your Website to Google Search Console 

●​ Click on “Add Property” (top-left corner). 
●​ Choose the property type: 

Domain Property (Recommended) – Covers all URLs (www, non-www, 
HTTP, HTTPS). 

URL Prefix – For a specific version (e.g., https://yourwebsite.com). 

●​ Enter your website URL and click "Continue." 
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Step 3: Verify Ownership 

Google needs to confirm that you own the website. You can verify using one of 
the methods below: 

Adding the HTML Tag in WordPress (Without Plugins) 

●​ Log in to WordPress Dashboard. 
●​ Go to Appearance > Theme Editor. 
●​ Locate the file header.php (under "Theme Files"). 
●​ Find the <head> section and paste the meta tag before the closing 
</head> tag. 

Click “Update File.” 
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Alternative for WordPress Users (Using a Plugin)​
If you don’t want to edit code manually, use the Insert Headers and Footers 
plugin: 

●​ Install and activate the Insert Headers and Footers plugin. 
●​ Go to Settings > Insert Headers and Footers. 
●​ Paste the HTML tag inside the "Scripts in Header" section. 
●​ Click Save Changes. 

Upload HTML File (Alternative) 

●​ Download the HTML verification file from Google. 
●​ Open your WordPress hosting file manager (via cPanel or FTP). 
●​ Go to public_html folder and upload the file. 
●​ Go back to Search Console and click "Verify."Verify via Domain Name 

Provider (Recommended) 
●​ Copy the TXT record provided by Google. 
●​ Open your domain provider's (GoDaddy, Namecheap, Bluehost, etc.) DNS 

settings. 
●​ Add a new TXT record and paste the copied value. 
●​ Save changes and go back to Search Console. 
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Click "Verify." It may take a few minutes. 

 

Step 4: Request Indexing for Your Pages/Posts 

Go to Google Search Console → URL Inspection Tool. 

Enter the URL of a blog post or page 
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Click Request Indexing. 

Repeat this process for important pages/Posts. 

 

Step 5: Submit Your WordPress Sitemap 

A sitemap helps Google crawl and index your website efficiently. 

Generate a Sitemap: 

Install and Activate the AIOSEO Plugin 

●​ Log in to your WordPress Dashboard. 
●​ Go to Plugins → Add New. 
●​ Search for All in One SEO. 
●​ Click Install Now and then Activate. 

Enable the Sitemap Feature 

●​ In the WordPress dashboard, go to All in One SEO → Sitemaps. 
●​ You will see the Enable Sitemap option. Make sure it is turned ON (toggle 

it if necessary). 
●​ Click Save Changes. 
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View Your Sitemap 

●​ After enabling the sitemap, scroll down and look for the Sitemap Preview 
section. 

●​ Click on the Open Sitemap button. 
●​ Copy that URL—you will need it for submitting to Google Search Console. 

Submit Your Sitemap to Google Search Console 

Once you have your sitemap URL 
(https://yourwebsite.com/sitemap.xml), submit it to Google Search 
Console: 

●​ Open Google Search Console. 
●​ Select your website property. 
●​ Click on Sitemaps in the left menu. 
●​ Paste your sitemap URL (only the ending part, e.g., sitemap.xml). 
●​ Click Submit. 

Google will now crawl your sitemap and start indexing your pages. 
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OFF PAGE SEO: 
Off-Page SEO refers to all the activities done outside your website to improve its 
ranking in search engines like Google. These techniques help increase website 
authority, trust, and visibility. 
 

What is a Backlink? 
A backlink (also called an inbound link or incoming link) is a link from one website 
to another. Backlinks help improve your website’s ranking in search engines like 
Google. 
 
Types of Backlinks: 

DoFollow (Most Valuable): 

A DoFollow  is a type of hyperlink that passes SEO (Search Engine Optimization) 
value, also known as "link juice," from one website to another.  

These links are important because they help search engines like Google determine the 
authority and relevance of a website. When a website links to your site with a DoFollow 
backlink, search engines recognize that as a vote of confidence, which can help 
improve your website’s search engine ranking. 
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NoFollow links: 

A NoFollow link is a type of hyperlink that tells search engines not to pass any SEO 
value, or "link juice," to the destination website. When a website adds a NoFollow 
attribute to a link, search engines like Google are instructed not to follow the link or use 
it to influence the linked site's ranking in search results. 

What is DA,PA,SS ? 

DA (Domain Authority), PA (Page Authority), and SS (Spam Score) are important 
metrics used in SEO to evaluate the quality and credibility of a website or webpage. 
Here's what each term means: 

DA: Measures the overall authority of a domain. 

PA: Measures the ranking potential of a specific page. 

SS: Measures the likelihood of a website being considered spammy. 

DA (Domain Authority): 

●​ Domain Authority (DA) is a metric developed by Moz that predicts how likely a 
website is to rank on search engines based on its overall authority and backlink 
profile. 

●​ It is scored on a scale from 0 to 100, with higher numbers indicating a higher 
likelihood of ranking well in search engine results. 

●​ A website with a high DA typically has a strong, well-established online presence, 
many high-quality backlinks, and good SEO practices. 

PA (Page Authority): 

●​ Page Authority (PA) is also a Moz metric, but it focuses on the strength of a 
specific webpage, rather than the entire domain. 

●​ Like DA, it is scored from 0 to 100 and predicts how well a specific page on a 
website will rank in search results. 

●​ A higher PA means that the page has more potential to rank for relevant search 
queries, often due to quality content, strong backlinks, and good on-page SEO. 
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SS (Spam Score): 

●​ Spam Score (SS) is a metric developed by Moz that measures the likelihood that 
a website may be penalized by search engines due to spammy or manipulative 
SEO practices. 

●​ It is a score between 0% and 100%, with higher percentages indicating a higher 
risk of being flagged as spam. 

●​ Spammy practices can include things like unnatural link-building, using 
low-quality content, or over-optimizing keywords. Websites with high Spam 
Scores are often considered risky and may be penalized in search engine 
rankings. 

Referring domain: 

A referring domain is a website that links to your site through a hyperlink. In other 
words, it’s a domain (website) that sends traffic or "link juice" to your website by linking 
to one of your pages.Each unique website that links to your site counts as one referring 
domain. 

Example Scenario: 

●​ Website A is a popular blog about gardening. 
●​ Website B is a gardening product shop. 
●​ Website C is a gardening forum. 
●​ Website D is a gardening news site. 

Backlinks: 

●​ Website A links to your website (1 backlink). 
●​ Website B links to your website (1 backlink). 
●​ Website B also links to your website again on another page (1 more backlink). 
●​ Website C links to your website (1 backlink). 
●​ Website D links to your website (1 backlink). 

In this scenario, you now have 5 backlinks, because there are 5 different links pointing 
to your site from 4 different websites. Even though Website B has linked twice, it only 
counts as one backlink for now because we are counting backlinks individually. 
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Referring Domains: 

●​ You have backlinks from Website A (1 referring domain). 
●​ You have backlinks from Website B (1 referring domain). 
●​ You have backlinks from Website C (1 referring domain). 
●​ You have backlinks from Website D (1 referring domain). 

Even though Website B linked to your site twice, it only counts as 1 referring domain 
because it’s a unique website. So, in total, you have 4 referring domains. 

●​ Backlinks = All the individual links pointing to your site. 
●​ Referring domains = The number of unique websites linking to your site. 

 

Off page Techniques : 

Off-page SEO techniques are actions you take outside your website to improve 
its search engine rankings. These techniques primarily focus on building 
backlinks, increasing brand visibility, and driving traffic to your site. 

Directory Submission: 

Directory Submission is an off-page SEO technique where you submit your 
website to online directories. These directories categorize websites based on 
niche or industry, allowing users to easily find relevant websites. When your 
website is listed in a directory, it provides a backlink, which can help improve your 
site's visibility, drive traffic, and potentially improve its SEO ranking. Submitting 
your website to online business directories or niche-specific directories. 

Directory Submission involves submitting your website to online directories to 
gain backlinks and increase visibility. 

First, you need to find relevant and reputable online directories where you can 
submit your website. These directories could be general (like Yellow Pages or 
Yelp) or niche-specific (like directories focused on technology, fashion, or local 
businesses). 

104 



 

 

Submitting Your Website: 

Once you’ve found a directory, go to the submission page. Most directories will 
ask you for: 

●​ Website URL: The address of your website. 
●​ Business Name: The name of your business or brand. 
●​ Description: A brief description of what your website is about. It’s 

best to include keywords related to your business or niche here for 
SEO purposes. 

●​ Contact Details: Email, phone number, and address (if applicable). 
●​ Category: You’ll need to select the correct category or subcategory 

that best fits your business or website. For example, a cleaning 
business would go under a “Home Services” category. 
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Blog commenting: 

Blog Commenting is an off-page SEO technique where you leave comments on 
other blogs or websites within your niche or industry, often with a link back to 
your own site. It helps build relationships with other bloggers, increase visibility, 
and can provide backlinks to improve SEO.Blog Commenting helps improve 
SEO by building backlinks, increasing traffic, and establishing authority. 
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Find Relevant Blogs: 

●​ Start by identifying blogs in your niche or industry. These are blogs where 
your target audience might be reading and engaging with the content. 

Don’t just leave a generic comment like “Great post!” or “I like this.” 

Web 2.0 sites: 

Web 2.0 sites refer to user-generated content platforms where users can create 
and share content, often in the form of blogs, articles, videos, images, and other 
media. These platforms allow individuals and businesses to create a profile, 
publish content, and interact with a larger community. In terms of SEO, Web 2.0 
sites are powerful tools for building backlinks, increasing visibility, and 
improving your site’s authority.Web 2.0 sites are platforms where you can create 
content that links back to your website, helping with SEO.These sites include 
WordPress, Medium, Blogger, Tumblr, Wix, Weebly etc. 
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Create a Profile and Build the Site: 

●​ Sign up for a free account on the chosen platform (e.g., Blogger, or Tumblr). 
●​ Create a profile with your business name, logo, and contact information. 

Add a short description of what your business does and link it back to your 
main website. 
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●​ Customize the theme to make it appealing and professional. Ensure that 
the layout matches your branding and resonates with your target audience. 

●​ Create Quality Content on Web 2.0 Sites 
●​ Add Internal and External Links 
●​ Include Backlinks to Your Main Website 
●​ Engage with the Community 

 

Classified Submission: 

Classified Submission to WordPress blogging websites refers to the process of 
submitting an ad or listing on classified ad websites that allow users to promote 
their business or services.This practice is beneficial for SEO because it 
generates backlinks, referral traffic, and increased exposure to a wider 
audience. 

Find WordPress-Based Classified Ad Websites 

Register and Create an Account 
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submit Your Classified Ad or Listing 

●​ After registering, navigate to the classified ad submission page or form. 
Most WordPress sites that support classified submissions have an 
easy-to-use form that asks for details about your business or service. 

●​ Fill out the form carefully: 

Title: Choose a relevant title that will grab attention  

Description: Write a detailed description of your business, offering value 
to potential clients. Focus on keywords relevant to your business, but keep 
it natural. 

Contact Information: Include your phone number, email address, and 
business website URL. 

Categories: Choose the most relevant category for your service  

Image or Logo: If the platform allows, upload an image or business logo 
to make your listing more attractive. 
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Image Submission: 

Image submission to WordPress blogging websites is the process of 
uploading and sharing images on WordPress-based blogs or websites. This is a 
common strategy for enhancing the content, improving SEO, and driving traffic to 
your site. The concept of "image submission" refers to adding images to blog 
posts, articles, and pages. 

Images can be used to improve user experience, visual appeal, and 
engagement, while also benefiting SEO if they are optimized correctly. 

Prepare Your Images for Submission: 

Optimize Image Size: Make sure your images are not too large to avoid slow 
loading times, which can negatively affect user experience and SEO. 

Image Format: Use common image formats like JPEG, PNG, or GIF, as they are 
widely accepted on most platforms. 

Publish the Content or Submit Your Image: 

After uploading your image and adding the necessary details, publish the 
content or submit the image for review. 
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Video Submission: 

Video submission is a powerful off-page SEO strategy that helps improve 
website rankings, drive traffic, and enhance brand visibility. This technique 
involves submitting videos to various video-sharing platforms, ensuring they are 
optimized for SEO. 
Create a High-Quality Video 

Optimize Video for SEO 

Before submission, optimize the following: 

●​ Title: Use a keyword-rich title (e.g., "Best SEO Off-Page Techniques to 
Rank #1") 

●​ Description: Add a 300-500 word SEO-friendly description, including links 
to your website and social media 

●​ Tags: Use 5-10 relevant keywords (e.g., SEO tips, video submission, digital 
marketing) 

●​ Thumbnail: Design an attractive, clickable thumbnail 

Choose the Right Video Submission Platforms 
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Submit and Share Your Video 

 

Infographic Submission: 
Infographic submission is a powerful off-page SEO strategy that helps 
generate high-quality backlinks, drive traffic, and increase engagement. This 
technique involves creating visually appealing data-driven graphics and 
submitting them to various infographic-sharing platforms. 
Create a High-Quality Infographic 

Optimize Your Infographic for SEO 

Before submission, optimize the following elements: 

●​ Title: Use a keyword-rich title (e.g., "Best Off-Page SEO Techniques – 
Infographic") 

●​ Description: Add a 200-300 word SEO-friendly description, including your 
website link 

●​ Image Name: Rename the file with keywords (e.g., 
best-seo-practices-2024.png) 

●​ Image Alt Text: Describe the infographic for search engines 
●​ File Size & Format: Use compressed PNG/JPEG for faster loading 
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Choose the Right Infographic Submission Platforms 
Visual.ly,Infographic Journal,Pinterest,Reddit,InfographicBee 

Submit & Promote Your Infographic 

 

Document Submission: 
Document submission is an off-page SEO strategy that involves submitting 
well-structured documents (PDFs, PPTs, DOCs) to high-authority 
document-sharing websites. This helps generate high-quality backlinks, improve 
search engine rankings, and drive traffic to your website. 
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Create a High-Quality Document 

Optimize the Document for SEO 

Before submission, optimize the following elements: 

●​ Title: Use an SEO-friendly title (e.g., "Top Digital Marketing Strategies – 
Free eBook") 

●​ Description: Add a 200-300 word SEO-optimized description, including 
your website link 

●​ File Name: Rename the file using keywords (e.g., 
seo-trends-2024.pdf) 

●​ Alt Text (for images inside PDFs): Describe visuals for better indexing 
●​ Links: Include clickable links to your website or services 

Choose the Right Document Submission Platforms 
SlideShare,Scribd,Google Drive (Public),DocDroid,Zoho Docs 
 
Submit & Promote Your Document 
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Forum Submission: 
Forum submission is an effective off-page SEO technique where you 
participate in online discussion forums related to your niche. By engaging in 
discussions, answering queries, and sharing valuable insights, you can build 
backlinks, drive targeted traffic, and improve domain authority. 
 
Find Relevant Forums in Your Niche 
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How to Find Forums?​
Use Google search operators: 

●​ “your keyword” + forum 
●​ “your keyword” + discussion board 
●​ “your keyword” + community 

Choose High-Authority Forum Submission Sites 

Quora,Warrior Forum,Digital Point,Moz Community 

Create an Account and Set Up Your Profile 

Engage & Contribute to Discussions 

Create Forum Threads & Answer FAQs 

Promote & Monitor Forum Engagement
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Article Submission: 

Article submission is an effective off-page SEO technique where you publish 
high-quality articles on third-party websites to gain backlinks, increase brand 
exposure, and drive organic traffic to your website. It helps in building authority, 
improving search rankings, and generating targeted visitors. 
 
Create a High-Quality, SEO-Optimized Article 

Optimize the Article for SEO 

Before submission, optimize the following elements: 

●​ Title: Use a keyword-rich, catchy title (e.g., "Top 10 SEO Strategies for 
2024") 

●​ Meta Description: Add a 150-160 character summary with keywords 
●​ Headings & Subheadings: Use H2, H3 for structured content 
●​ Internal & External Links: Link to relevant internal pages and 

high-authority sites 
●​ Image Optimization: Add alt text and descriptive file names 
●​ Anchor Text: Use a natural anchor text for backlinks  

Choose High-Authority Article Submission Sites 
Medium,EzineArticles,HubPages,ArticleBiz,LinkedIn Articles 
Submit & Promote Your Article 
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Social Bookmarking: 

Social bookmarking is an effective off-page SEO technique where you submit 
your website or content to high-authority bookmarking sites to generate 
backlinks, drive traffic, and improve search engine rankings. 

When you bookmark your content on these platforms, search engines quickly 
index your page, improving its visibility in search results. 

Choose High-Authority Social Bookmarking Sites 

Reddit,Mix (formerly StumbleUpon),Flipboard,Pocket 
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Prepare Content for Bookmarking 

Submit Content on Social Bookmarking Sites 

Promote Your Bookmarking Posts
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Guest Blogging: 

Guest blogging, also known as guest posting, is an off-page SEO strategy 
where you write high-quality articles for other websites in your niche. In return, 
you gain backlinks to your site, enhance brand authority, and drive referral traffic. 
 
 Find High-Authority Guest Blogging Sites 

●​ "write for us" + [your niche] 
●​  "guest post by" + [your niche] 

 
 
Choose High-DA Guest Posting Sites 
HubSpot Blog,Search Engine Journal,ShoutMeLoud,Business2Community 
Write a High-Quality Guest Post 
Include Strategic Backlinks in Your Guest Post 
Submit Your Guest Post & Engage with the Audience 
 
How to Approach Guest Blogging: 

When reaching out for guest blogging opportunities, there are two primary ways 
to contact website owners: 
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 Email Outreach (Direct approach) - Email is the best way to approach website 
owners because it is direct, professional, and allows for personalization. 

 

​
 Contact Form Submission (Website inquiry form) - If a blog does not provide 
an email address, they often have a contact form where you can send your 
request. 
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Both methods can be effective, but they require different strategies. 

Google My Business (GMB) & Local SEO: 

Marking the physical presence of your business on google is known as Google 
my business.Google My Business (GMB) optimization and Local SEO are 
crucial off-page SEO techniques that help businesses improve their visibility in 
Google Search and Google Maps. These strategies are essential for local 
businesses, service providers etc to attract customers in their area. 
 
Create & Verify Your Google My Business Profile 

●​ Visit Google My Business and click "Manage Now" 
 

 
●​ Enter Business Name (Use the exact name as on your website and 

listings) 
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●​ Choose Business Category (e.g., “Plumber,” “SEO Agency,” “Restaurant”) 
●​ Add Physical Address (If applicable) or select Service Area 
●​ Enter Phone Number & Website URL 
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●​ Complete Verification Process (Google will send a verification code via 
mail, phone, or email) 

Optimize Your GMB Profile for Maximum Visibility 
Get More Positive Google Reviews (Social Proof) 
Optimize for “Near Me” and Local Keywords 
Local Link Building 
Post Regular Updates on GMB 

 
 
 

 

Profile Creation: 

Profile creation is an effective off-page SEO strategy where you create 
business or personal profiles on high-authority websites to get backlinks, 
improve search rankings, and increase brand visibility. 
 

●​  Find High-Authority Profile Creation Sites 
           LinkedIn,Facebook Business Page,Flickr,About.me,Quora 

●​ Create a Professional Profile with SEO Optimization 
●​ Engage & Maintain Your Profile for SEO Benefits. 
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TECHNICAL SEO: 
Technical SEO refers to the process of optimizing the technical aspects of a 
website to improve its search engine rankings. While on-page SEO deals with 
content and user experience, and off-page SEO focuses on backlinks, technical 
SEO focuses on the backend of a website and its infrastructure to make it easier 
for search engines to crawl, index, and rank the site. 
 

Website Speed Optimization - Page load time is a ranking factor for Google, 
and users expect websites to load quickly. 
Mobile Friendliness - Google uses mobile-first indexing, meaning it primarily 
looks at the mobile version of your website when ranking it. 
Site Structure and URL Optimization - A clear and logical structure helps 
search engines crawl your site efficiently and makes it easier for users to 
navigate 
Fixing Crawl Errors - Crawl errors can prevent search engines from indexing 
your pages, which can hurt rankings. 
HTTPS (Secure Website) - Google considers HTTPS as a ranking factor, and 
users are more likely to trust a secure site.  
Structured Data (Schema Markup) - Structured data helps search engines 
understand the content of your site better, which can lead to rich snippets (e.g., 
star ratings in reviews). 
 

 Sitemap: 
 A sitemap means shortest route to locate a particular page/post/product inside a 
website. A sitemap is a file that lists all the pages on your website to help search 
engines understand the structure of your site and find all your content more 
efficiently. It acts like a map for search engines, guiding them to all important 
pages. 

Types of Sitemaps: 

●​ XML Sitemap(server): This is the most common type for SEO purposes. It 
is primarily for search engines (like Google or Bing) and tells them about all 
the pages on your site that you want indexed. 
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●​ HTML Sitemap(users): This is more for users, providing them with a 
structured list of your website’s pages. While not directly tied to SEO, it can 
improve user navigation. 

Generate an XML Sitemap: 

There are various ways to generate an XML sitemap for your website: 

For WordPress: You can use plugins like All in one seo or RankMath. Once 
installed, these plugins will automatically generate and update the sitemap for 
you. For example, in Yoast, the sitemap URL might be 
https://www.yourwebsite.com/sitemap_index.xml. 

 

How to check site map in SEOQUAKE: 

Install SEOQUAKE -> Diagnosis -> xml sitemaps  

 

To check a sitemap using SEOquake, follow these steps: 

●​ Install SEOquake: If you haven't already, install the SEOquake browser 
extension. It's available for both Chrome and Firefox. 
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●​ Open the website: Go to the website you want to analyze. 
●​ Activate SEOquake: Click on the SEOquake icon in your browser's toolbar 

to activate it. 
●​ Check the sitemap: 

In the SEOquake toolbar, click on the "Diagnosis" tab. 

Scroll down, and under the "Sitemap" section, you can see the link to the 
sitemap of the website if it’s available. 

Alternatively, if the website has a sitemap.xml file, you can directly check 
the URL by appending "/sitemap.xml" to the website's domain (e.g., 
https://www.example.com/sitemap.xml). 
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How to create HTML sitemap for users in All in one seo plugin: 

All in one seo plugin -> sitemap ->Enable HTML Sitemap -> Display HTML 
sitemap [shortcode] -> copy short code -> Generate the HTML Sitemap Page -> 
Publish the Sitemap Page -> Add the Sitemap to Your Navigation (Menus). 

 
 

●​ Go to All in One SEO in your WordPress dashboard. 
●​ Click on Sitemaps from the plugin's settings menu. 
●​ Ensure that XML Sitemap is enabled for your website (this will 

automatically generate an XML sitemap for search engines). 
●​ Scroll down to the HTML Sitemap section within the Sitemap settings. 
●​ Turn on the option for the HTML Sitemap. This allows the plugin to 

generate a user-friendly HTML sitemap. 
●​ Copy short code 
●​ Add the HTML Sitemap to Your Website - Go to Pages or Posts from your 

WordPress dashboard. 
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Robots.txt: 
Telling Google to not crawl a particular page/post/product.robots.txt is a simple 
text file used to give instructions to web crawlers (also known as robots or bots) 
about which pages or sections of a website they are allowed or disallowed to 
crawl and index.  
 

Using a Plugin to Manage robots.txt: 

Using All in One SEO Plugin 

All in one seo -> Tools -> Add Rule(*/Allow/Disallow/page url)  

Install All in One SEO: 

           From your WordPress dashboard, go to Plugins > Add New. 

  Search for "All in One SEO" and click Install Now and Activate. 

Access the Robots.txt Editor: 

Go to All in One SEO > Tools. 
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Edit the Robots.txt File: 

●​  Under the Robots.txt section, you’ll see a box where you can edit the file 
content 

●​  You can add or remove instructions here directly. 

Save Changes: 

After editing, click Save Changes. 

 

Check the robots.txt file: 

Visit http://yourwebsite.com/robots.txt to ensure your changes are 
reflected. 

How to do manually in All in one SEO plugin: 

Go to required page/post/product -> scroll bottom to All in one SEO -> Advanced 
->Disable use default settings -> click on Robots meta as your requirements( No 
index,No follow,No image index etc). 
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Redirections: 

Redirections are a way of forwarding both users and search engines from one 
URL to another. This is often done when content is moved, deleted, or replaced. 
Redirections ensure that visitors are still able to access content without 
encountering errors or broken links, and they also help maintain SEO value by 
transferring the link equity (ranking power) from the old page to the new one. 
 
There are several types of redirections, but the most common ones are 
301 redirects (permanent)  - Used when a page has permanently moved to a 
new location 
302 redirects (temporary) - Used when a page is temporarily moved or 
unavailable. This could happen when you’re conducting maintenance or testing a 
new page temporarily. 

How to Set Up Redirections in WordPress 

step 1: Install and Activate the Redirections Plugin 

●​ Go to your WordPress dashboard. 
●​ Navigate to Plugins > Add New. 
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●​ In the search bar, type Redirections by Web Factory Ltd. 
●​ Click Install Now next to the plugin. 
●​ Once installed, click Activate. 

 

Step 2: Access the Redirections Plugin 

 After activation, go to Tools > Redirections in your WordPress dashboard.      
This is where you can manage all your redirects. 

Step 3: Add a New Redirect 

●​ Once in the Redirections section, you'll see a screen with a list of existing 
redirects (if any) and options to add new ones. 

●​ Click the Add New Redirect button to create a new redirect. 

Step 4: Set Up the 301 Redirect 

Source URL: In the "Source URL" field, enter the old URL you want to redirect. 
Make sure you only enter the path after the domain name. For example: 

●​ Old URL: https://www.yourwebsite.com/old-page 
●​ Enter in the Source URL: /old-page 
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Target URL: In the "Target URL" field, enter the new URL to which you want to 
redirect users. Make sure to include the full URL, including the https:// or 
http:// part. 

●​ New URL: https://www.yourwebsite.com/new-page 

For example: 

●​ Source URL: /old-page 
●​ Target URL: https://www.yourwebsite.com/new-page 

Choose Redirect Type: 

●​ Below the URL fields, you’ll see a dropdown menu labeled Redirection 
Type. 

●​ From the dropdown, select 301 Moved Permanently. This is the best option 
when the page has permanently moved to a new location. 

Click Add Redirect: After filling in the fields, click the Add Redirect button to save 
the 301 redirect. 
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What is a 307 Redirect? 

A 307 Redirect is a temporary HTTP status code used to indicate that the 
requested resource has temporarily moved to a different location. It's similar to a 
302 Redirect but more specific, as it preserves the request method (e.g., GET or 
POST) during the redirect. This means if someone sends a POST request, the 
server responds with a 307 status code, and the browser will send the POST 
request to the new URL instead of a GET request, which would happen with 
other redirects like 301 or 302. 

 Orphan pages: 

Orphan pages are web pages on a website that are not linked to from any other 
pages within the same website. In other words, these pages are isolated and can 
only be accessed by entering their URL directly or via search engines. Orphan 
pages typically don’t have any internal backlinks pointing to them, making them 
harder to find for both users and search engines. 
 

Canonical Tag: 
Avoid Duplicate Content: Duplicate content can negatively impact SEO because 
search engines may struggle to determine which version of a page should rank 
higher. The canonical tag clarifies which version of a page should be considered 
the original or most authoritative. 
If multiple pages with similar content exist, the canonical tag helps ensure that 
the SEO value of the content (such as backlinks and search engine ranking) is 
directed to the preferred URL rather than being split between different pages. 
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Schema: 

Schema refers to Schema Markup or Structured Data, which is a type of code 
added to the HTML of a webpage to help search engines better understand the 
content of the page. This data provides context and details about the information 
on the page, allowing search engines to display rich snippets, enhance search 
results, and improve visibility. 
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What is Schema Markup? 
Schema markup is a form of structured data based on a standardized vocabulary 
developed by Schema.org, a collaborative project between major search engines 
like Google, Bing, Yahoo, and Yandex. It helps search engines interpret the data 
on a page and present it in a more informative and user-friendly way. 
For example, instead of just showing the title and URL of a page in search 
results, schema markup can help show additional details like reviews, ratings, 
images, event dates, and other relevant information. 
 

Google Search Console (GSC) dashboard: 
The Google Search Console (GSC) dashboard is a free tool provided by Google 
that helps website owners, webmasters, and SEO professionals monitor, 
maintain, and troubleshoot their site's presence in Google Search results. It 
provides valuable insights into how Google crawls and indexes your site, as well 
as feedback on how your site appears in search results. 
 
Key Features and Sections of the Google Search Console Dashboard: 
1. Performance Report: 

●​ Overview: This section shows how your site is performing in Google 
Search, providing metrics like total clicks, total impressions, average 
click-through rate (CTR), and average position in search results. 

●​ Key Metrics: 
●​ Total Clicks: The number of times users clicked on your website from 

Google Search. 
Total Impressions: How often your site appears in search results. 
Average CTR: The percentage of impressions that resulted in a click. 

●​ Average Position: The average ranking position of your site’s pages in 
search results. 

●​ Filters: You can filter data by queries, pages, countries, devices, and dates 
to get more granular insights into how your site performs for specific 
keywords or regions. 
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2. Coverage Report: 

●​ Overview: This report shows how Google crawls and indexes your website, 
identifying any issues that might prevent Google from fully crawling your 
pages. 

●​ Key Sections: 
●​ Valid Pages: Pages that are successfully crawled and indexed by Google. 
●​ Errors: Pages that have issues, preventing them from being indexed. 

Common errors include 404 (page not found), 500 (server errors), and 
redirects. 

●​ Valid with Warnings: Pages that are indexed but have some issues (e.g., 
slow loading time or mobile usability issues). 

●​ Excluded: Pages that Google has intentionally excluded from indexing, 
such as duplicates or pages blocked by robots.txt. 

●​ Actions: You can request Google to re-crawl fixed pages through the 
"Validate Fix" option. 
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3. URL Inspection Tool: 
Overview: This tool allows you to check how a specific URL is being indexed by 
Google. It shows if the URL is indexed, if there are any issues, and whether 
Google can crawl the page properly. 
Key Information: 

●​ Live Test: Shows if the page is accessible to Google's crawlers in real-time. 
●​ Index Status: Whether the page is indexed and how it appears in search 

results. 
●​ Crawl Errors: Identifies any issues Google encountered while crawling the 

page. 
●​ Rich Results: If the page uses schema markup, this tool will tell you if 

Google is able to read the structured data correctly. 
 
 
4. Sitemaps: 
Overview: This section allows you to submit your website’s sitemap to Google, 
helping search engines discover your pages more efficiently. 
Actions: 
Submit a new sitemap. 
Check the status of previously submitted sitemaps. 
View how many pages in your sitemap have been crawled and indexed by 
Google. 
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5. Mobile Usability: 
Overview: This report shows any mobile usability issues on your website, which 
is important for SEO because Google uses mobile-first indexing. 
Key Issues: 
Text too small to read 
Content wider than the screen 
Clickable elements too close together 
Actions: Fix the issues listed to improve your site’s mobile experience. 
6. Links Report: 
Overview: This section shows the internal and external links to your website. 
External links (backlinks) are a significant ranking factor in SEO. 
Key Sections: 
Top Linked Pages: Displays the most linked pages on your site. 
Top Linking Sites: Shows which websites link to your site the most. 
Internal Links: Displays the internal linking structure of your website. 
Actions: Use this data to monitor your link profile and see which pages are 
gaining the most backlinks. 
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7. Core Web Vitals: 
Overview: This section focuses on user experience signals, specifically the 
performance of your site based on the Core Web Vitals, which include: 

●​ Largest Contentful Paint (LCP): Measures how long it takes for the largest 
visible content element to load on a page. 

●​ First Input Delay (FID): Measures how quickly the site responds to user 
interaction (e.g., clicks). 

●​ Cumulative Layout Shift (CLS): Measures visual stability, ensuring that 
page elements don’t move unexpectedly during loading. 

 
 

Google Disavow Tool: 
The Google Disavow Tool is a feature provided by Google in Google Search 
Console that allows website owners to tell Google to ignore certain backlinks to 
their site when evaluating its SEO and ranking. This tool is typically used to 
address situations where a website has unnatural, low-quality, or spammy 
backlinks pointing to it, which may harm its ranking in search results. 
 
Steps to Use the Google Disavow Tool: 
Identify Harmful Backlinks: 
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First, identify backlinks that may be harmful or low-quality. Tools like Google 
Search Console, Ahrefs, SEMrush, and Moz can help you audit your backlink 
profile. 
Look for links from irrelevant, spammy, or low-authority sites that could potentially 
hurt your website’s SEO. 

 
Prepare a Disavow File: 
Create a plain text file (.txt) with the list of URLs or domains you want to disavow. 
You can disavow individual URLs or entire domains. 
The format for the file is simple: 
To disavow a specific URL: 
perl 
Copy 
https://www.example.com/spammy-link 
To disavow an entire domain (all links from that domain): 
makefile 
Copy 
domain:spammydomain.com 
Ensure the file contains one URL or domain per line. You can add comments in 
the file by using the # symbol at the beginning of the line, e.g., # This is a 
comment. 
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Submit the File to Google Search Console: 
Go to the Google Disavow Tool page in Google Search Console. 
Choose the property (website) for which you want to disavow links. 
Upload the .txt file you created with the list of URLs or domains to be disavowed. 
Once submitted, Google will process the file and ignore the links during its 
ranking evaluation. 

 
 
Monitor the Results: 
After submitting the disavow file, Google may take several weeks to process the 
request. There's no immediate effect, and Google will not notify you when they’ve 
processed the file. 
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Site Audit: 
A Site Audit in SEO is a comprehensive analysis of a website’s performance, 
structure, and optimization issues. It helps identify technical, on-page, and 
off-page SEO problems that could affect the website’s search engine rankings 
and user experience. 

A site audit typically examines: 

●​ Technical SEO issues (crawlability, indexability, speed) 
●​ On-page SEO factors (meta tags, content optimization) 
●​ Off-page SEO factors (backlinks, domain authority) 
●​ User Experience (UX) & Mobile-Friendliness 
●​ Security issues (HTTPS, malware, etc.) 

 Step-by-Step Guide: Performing a Site Audit for a WordPress 
Blog in SEMrush 
 
 
 
 
 
Step 1: Set Up Site Audit in SEMrushTool: SEMrush Site Audit 

 Practical Steps: 

●​ Log in to SEMrush → Go to "Site Audit" under SEO Dashboard. 
●​ Click “+ New Project”, enter your WordPress website URL, and click 

Create Project. 

Click Start Audit and wait for SEMrush to scan your site. 
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Step 2: Fix Technical SEO Issues 

 Focus: Indexing, Crawlability, Speed, HTTPS 

 Practical Steps: 

1.​Check Crawlability Issues: 
○​ Navigate to Site Audit > Crawlability. 
○​ Look for Blocked Pages (robots.txt), Orphan Pages, and 404 

Errors. 
○​ Fix: 

Use Rank Math / Yoast SEO to edit robots.txt for correct crawling. 

Redirect 404 pages using the Redirection plugin. 

2.​Check HTTPS & Security Issues: 
○​ If SEMrush flags SSL issues, ensure your WordPress site has 

HTTPS enabled (use Really Simple SSL plugin). 
○​ Scan for malware using Wordfence Security Plugin. 

3.​Optimize Website Speed: 
○​ SEMrush will highlight slow-loading pages under Performance 

Report. 
○​ Fix: 

Install WP Rocket for caching. 

Optimize images with ShortPixel or Smush. 

Use a CDN (Cloudflare, BunnyCDN) for faster delivery. 

 

Step 3: Fix On-Page SEO Issues 

 Focus: Meta tags, Keyword Optimization, Duplicate Content 

Step 4: Fix On-Page SEO Issues 
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 Focus: Meta tags, Keyword Optimization, Duplicate Content 

Step 5: Analyze Backlinks & Off-Page SEO 

 Focus: Link Building & Toxic Links 

 

 

Competitor Analysis: 

Competitor Analysis in SEO is the process of identifying and analyzing the 
websites that compete with you in search rankings. By understanding their 
strengths and weaknesses, you can optimize your WordPress blog to outrank 
them. 
 
 Step-by-Step Guide: Competitor Analysis for a WordPress Blog in 
SEMrush 
Step 1: Identify Your SEO Competitors 

Tool: SEMrush Organic Research 

 Practical Steps: 

●​ Log in to SEMrush and go to "Organic Research" under SEO 
Dashboard. 

●​ Enter your WordPress blog’s domain. 
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●​ Scroll down to the “Main Organic Competitors” section. 
●​ SEMrush will show a list of competing domains that rank for similar 

keywords. 

Step 2: Analyze Competitors’ Top-Ranking Keywords 

Tool: SEMrush Keyword Gap Tool 

 Practical Steps: 

●​ Go to "Keyword Gap" under SEO > Competitive Research. 
●​ Enter your blog’s domain and 3-5 competitor websites. 
●​ SEMrush will show: 

​Shared keywords (where you compete). 
​Missing keywords (keywords they rank for but you don’t). 
​Weak keywords (where they rank higher than you). 

Step 3: Analyze Competitors’ Content Strategy 

Step 4: Analyze Competitors’ Backlink Strategy 

 Tool: SEMrush Backlink Analytics & Backlink Gap 

 Practical Steps: 

●​ Go to Backlink Analytics → Enter your competitor’s domain. 
●​ SEMrush will show who is linking to them. 
●​ Identify high-authority domains linking to competitors but not to you. 
●​ Use Backlink Gap Tool to compare backlinks between you and 

competitors. 

Step 5: Check Competitors' Technical SEO 

 Tool: SEMrush Site Audit 

 Practical Steps: 

●​ Go to Site Audit → Enter your competitor’s domain. 
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●​ SEMrush will show technical SEO issues like: 
○​ Slow loading pages 
○​ Mobile usability issues 
○​ Broken links 

 

 

 

Grammarly: 

Grammarly is an AI-powered writing assistant tool that helps improve 
grammar, spelling, punctuation, clarity, and style in writing. It is widely used 
by bloggers, writers, students, and professionals to enhance their content. 

How to Use Grammarly Practically? 
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Step 1: Install or signup Grammarly  

 

Step 2: Check and Correct Grammar Errors 

Example Sentence (Before Correction):​
 "This blog post have many informations that is very usefull for peoples." 

 

 Corrected Sentence (After Grammarly Fixes):​
 "This blog post has a lot of useful information for people." 
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Step 3: Improve Clarity and Readability 

Step 4: Check for Plagiarism (Premium Feature) 

Paste text into Grammarly. 

Click Plagiarism Checker → It highlights copied sections. 

Rewrite or cite sources if needed. 

 

What is AIPRM? 

AIPRM (AI Prompt Marketplace) is a Chrome extension designed to enhance 
ChatGPT by providing pre-built AI prompts for various use cases, including 
SEO, content writing, digital marketing, and sales automation. 

How to Use AIPRM Practically for Digital Marketing 

 Step 1: Install AIPRM Extension 

 Practical Steps: 

●​ Open Google Chrome. 
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●​ Go to the AIPRM Chrome Extension page. 
●​ Click "Add to Chrome" and install the extension. 
●​ Log in to ChatGPT (OpenAI) → AIPRM will appear inside ChatGPT. 

 

Step 2: Select a Pre-Built  Prompts 

 Practical Steps: 

●​ Open ChatGPT. 
●​ Click on the AIPRM tab (you will see multiple prompt categories). 
●​ Choose a prompt template based on your marketing goal: 

○​ SEO & Keyword Research 
○​ Content Creation (Blog Writing, Product Descriptions, etc.) 
○​ Social Media Marketing (Ad Copy, Twitter & Instagram Posts) 

 Example: If you need a keyword research strategy, select an SEO-related 
AIPRM prompt. 
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What is QuillBot? 

QuillBot is an AI-powered paraphrasing and writing assistant tool that helps 
users rewrite, summarize, and improve their content. It is widely used by writers, 
students, bloggers, and digital marketers to enhance the quality of their 
writing. 

Access QuillBot: 

 Options: 

●​ Website: Go to QuillBot.com 
●​ Chrome Extension: Install QuillBot for Chrome 
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Paraphrasing Text with QuillBot: 

 Practical Steps: 

●​ Open QuillBot Paraphrasing Tool. 
●​ Copy and paste your text into the input box. 
●​ Select a paraphrasing mode: 

○​ Standard: Balanced rewriting 
○​ Fluency: Improves readability 
○​ Formal: Professional tone 
○​ Creative: Generates unique variations 

●​ Click "Paraphrase" → QuillBot generates a rewritten version. 
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Original Text:​
"Content marketing is essential for digital businesses to attract and retain 
customers." 

 QuillBot Output (Paraphrased):​
"For digital businesses, content marketing is crucial in engaging and keeping 
customers." 

 

 

Grammar & Spell Checking 

 

 SEMrush: 

SEMrush is an all-in-one digital marketing tool used for SEO, keyword 
research, competitor analysis, content marketing, PPC (pay-per-click), and 
social media management. 
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Create a SEMrush Account 

●​ Go to SEMrush.com. 
●​ Sign up for a free or paid account. 
●​ Access the SEMrush Dashboard, where you can explore SEO tools. 

 

Perform Keyword Research for SEO 

Go to Keyword Overview in SEMrush. 

Enter a keyword (e.g., "best Digital marketing course"). 

SEMrush will display: 

●​ Search Volume (How many people search for it monthly). 
●​ Keyword Difficulty (KD%) (How hard it is to rank). 
●​ CPC (Cost Per Click) (If you’re running ads). 
●​ Related & Long-tail Keywords. 
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Analyze Competitor Websites 

 Use Case: Find out which keywords your competitors rank for. 

●​ Open SEMrush > Domain Overview. 
●​ Enter a competitor’s website (e.g., “travelblog.com”). 
●​ SEMrush will display: 

○​ Top organic keywords. 
○​ Traffic sources. 
○​ Backlinks (who is linking to them?). 
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Conduct a Site Audit (SEO Health Check) 

 Use Case: Find & fix SEO errors on a WordPress website. 

●​ Go to SEMrush > Site Audit. 
●​ Enter your website URL (e.g., myblog.com). 
●​ SEMrush scans for: 

○​ Broken links. 
○​ Slow loading speed. 
○​ Missing meta descriptions. 
○​ Duplicate content issues. 

Find Backlink Opportunities 

●​ Go to SEMrush > Backlink Analytics. 
●​ Enter a competitor’s domain. 
●​ Find who links to them and outreach for backlinks. 
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Ubersuggest: 

Ubersuggest is an SEO and digital marketing tool created by Neil Patel. It 
helps with keyword research, competitor analysis, backlink tracking, and 
site audits to improve website rankings on Google. 

Create an Ubersuggest Account 

●​ Go to Ubersuggest.com. 
●​ Sign up for a free or paid account. 
●​ Access the SEO Dashboard for keyword research, competitor analysis, 

and more. 

 

Perform Keyword Research 

●​ Open Ubersuggest > Keyword Overview. 
●​ Enter a keyword (e.g., "best travel destinations"). 
●​ Ubersuggest displays: 

○​ Search Volume (How many people search for it monthly). 
○​ SEO Difficulty (SD) (How hard it is to rank). 
○​ CPC (Cost Per Click) (For paid ads). 
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○​ Content ideas & related keywords. 

 

 Analyze Competitor Websites 

●​ Open Ubersuggest > Traffic Analyzer. 
●​ Enter a competitor’s website (e.g., “travelblog.com”). 
●​ Ubersuggest will display: 

○​ Top organic keywords. 
○​ Estimated traffic. 
○​ Backlink profile. 
○​ Top-performing blog posts. 
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GOOGLE ADS(SEM) 

What is Google Ads? 
Google Ads is an online advertising platform developed by Google where 
advertisers can display ads to users based on their search queries, browsing 
behavior, or interests.  
 

How Google Ads Works: 

Ad Auction: Google Ads operates on an auction system. Advertisers bid on 
keywords (words or phrases people search for on Google) that they want their 
ads to appear for. When a user performs a search, Google runs an auction to 
determine which ads will appear and in what order. 

Ad Formats: 

○​ Search Ads: These appear when someone types a query into 
Google’s search bar. For example, if someone searches for "custom 
t-shirts," your ad might appear at the top or bottom of the search 
results. 

○​ Display Ads: These are visual banner ads that appear on websites 
within Google’s Display Network. 

○​ Video Ads: These appear on YouTube or other Google-owned 
platforms. 

○​ Shopping Ads: For e-commerce businesses, these show product 
images and prices directly in the search results. 

○​ App Ads: Promote apps across Google networks like the Play Store, 
YouTube, and other apps. 

Keyword Targeting: You select keywords that are relevant to your business. 

Ad Quality Score: Google assigns a "Quality Score" to your ads, which is based 
on the relevance of your keywords, the quality of your ad, and the landing page 
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experience. The higher your Quality Score, the less you might need to bid to get 
your ads shown. 

Budget and Bidding: You set a daily budget for your ads, and you can choose 
how you want to bid (e.g., cost-per-click (CPC), cost-per-impression (CPM), or 
cost-per-acquisition (CPA)). 

What is CPC and PPC  

CPC (Cost-Per-Click): 

CPC refers to the amount an advertiser pays when a user clicks on their ad. 

How CPC Works: 

●​ You bid on certain keywords, and each time someone clicks on your ad, you 
pay a predetermined amount. The cost can vary depending on factors like 
keyword competition, your Quality Score, and how much you bid. 

●​ Example: If you are advertising a custom t-shirt business and you bid $2 for 
the keyword "custom t-shirts," you’ll pay $2 each time someone clicks your 
ad. 

PPC (Pay-Per-Click): 

PPC is the broader advertising model that includes CPC but can also cover other 
types of payment models based on clicks or actions. 

How PPC Works: 

●​ PPC is the advertising model, while CPC is one of the pricing 
strategies within PPC. 

●​ With PPC, advertisers pay based on clicks (CPC) or other actions like 
impressions (CPM – Cost-Per-Thousand Impressions) or acquisitions (CPA 
– Cost-Per-Acquisition). 

●​ Example of PPC Platforms: Google Ads, Bing Ads, Facebook Ads, etc. 
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CPC is a specific pricing model under the broader PPC umbrella. It only refers to 
paying for actual clicks on your ad. 

PPC refers to the entire advertising model where you pay for interactions with 
your ads (whether that's clicks, impressions, or other actions). 

What is impression? 

Impressions refer to the number of times an ad is displayed on a user’s screen, 
regardless of whether or not they click on it. In other words, an impression is 
counted every time your ad is shown to a user, even if they don't interact with it. 

Click-Through Rate (CTR) 

Click-Through Rate (CTR) is a metric used in online advertising that measures 
how often people click on your ad after seeing it. It's expressed as a percentage 
and indicates the effectiveness of your ads in encouraging users to take action 

CTR Formula: 

The formula to calculate CTR is: 

CTR=(No.of clicks/Total No. of impressions) * 100 

Where: 

●​ Clicks = The total number of times your ad was clicked. 
●​ Impressions = The total number of times your ad was shown. 

Structure of Google Ads: 
Google Ads is structured in a hierarchical way that helps you organize your 
advertising campaigns efficiently. The structure consists of Accounts, 
Campaigns, Ad Groups, and Ads. 
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How to create Google Ads account 
Step 1: Go to Google Ads 
Go to the Google Ads website: Google Ads. 
Click on "Start now" to begin the process. 
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Step 2: Set Up Your Google Ads Account 

Confirm Your Account Settings: 

First, make sure you enter the correct details for your Google Ads account. 

●​ Billing Country: 
●​ Select the country where your business operates, as this will determine 

your billing details and applicable tax rates.  
●​ Timezone: 
●​ Set your account’s timezone to match the location where you primarily 

operate. This ensures your ads are scheduled according to the correct local 
time.  

●​ Currency 
●​  Choose the currency you want to use for billing. 

 

●​ Payments Profile: 
●​ Choose Individual if you're setting up the account for personal use or for a 

small business. If you're setting up a business account, you can opt for 
Business. 
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●​ Payment Method: 
●​ Select your preferred payment method, such as a credit or debit card. Enter 

the necessary payment details to activate your Google Ads account 
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Step 3: Create a New Campaign 

●​ Click the + New Campaign button on the homepage. 
●​ You'll be prompted to choose a campaign goal. For a Search Network 

campaign,depending on your objectives. 

 

Choose the Campaign Type 

●​ Search Campaigns: Ads that show up on Google search results. 
●​ Display Campaigns: Banner ads on websites in Google’s network. 
●​ Video Campaigns: YouTube ads. 
●​ Shopping Campaigns: For online stores (if you’re selling physical 

products). 
●​ Under Campaign Type, select Search. 
●​ Then choose Search Network. 

     Click on Search (Any network as per your requirement). 
●​ Set Campaign Name: Choose a name that’s easy to remember and 

reflects your goal.  
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●​ Set Your Target Locations: You can choose to target specific countries, 
regions, or even specific cities. 

●​ Set Languages: You can target specific languages, like English, Spanish, 
etc. 

●​ Choose Your Bidding Strategy: For beginners, Google will typically 
recommend automated bidding like Maximize Conversions or Maximize 
Clicks, which is easy and effective for a first-time campaign. You can also 
set a specific cost-per-click (CPC) limit, but Google’s automated bidding will 
manage your budget for you. 

 
Step 4:Create Ad Groups 
An Ad Group is a collection of ads that share similar targeting. 
Ad Group Name: This is a way to group similar ads and keywords. 
Keywords: Add relevant keywords to your ad group. Google will use these to 
match your ad to searches. Use the Keyword Planner Tool to discover the best 
keywords for your campaign. 
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 Create Ads 

●​ Final URL: This is the landing page that users will be directed to when 
they click your ad. 

●​ Headlines: Google allows up to 3 headlines (up to 30 characters 
each). Make them relevant, action-oriented, and keyword-focused. 

●​ Description: Write 2 descriptions (up to 90 characters each) to 
describe your offer or product. Include your unique selling points and 
call to action. 
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keyword match types: 

Broad Match: 
Broad match is the default match type. It triggers your ad for any search that 
includes your keyword in any order, along with synonyms and related terms. It 
reaches the widest audience, but it can be less targeted. 
If your keyword is "Digital Marketing" 
Digital Marketing for students 
Digital Marketing for House wives 

Phrase Match: 

We should not disturb pattern.With phrase match, the search query must contain 
the exact phrase you’ve selected (or close variations) in the same order, though 
other words can come before or after. 

Example: 

●​ If your keyword is "Digital marketing course" (in quotation marks), your ad 
could show for: 

○​ "Digital marketing course in telugu 
○​ "Digital marketing course in online" 

Exact Match: 

Exact match is the most restrictive keyword match type. Your ad will only show 
when the search query exactly matches the keyword (or close variations like 
misspellings or plurals). 

Example: 

●​ If you use "Digital marketing" as your exact match keyword, your ad would 
only appear for searches like: 

○​ "Digital marketing" 
○​ "Digital market" (close variant) 
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Negative Match 

Negative match is used to prevent your ad from showing on certain search 
queries. It helps you avoid irrelevant traffic that could waste your budget. 

Example: 

Free Digital marketing  

What is Digital marketing  
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Extensions: 
Extensions in Google Ads are additional pieces of information that can be added 
to your ads to provide more value to users and improve your ad’s performance. 
These extensions help your ad stand out, increase click-through rates (CTR), 
and give users more reasons to click on your ad. 
 

 

Sitelink Extensions: 
Sitelink Extensions allow you to add additional links beneath your main ad text, 
directing users to specific pages on your website. These links help users find 
exactly what they’re looking for without needing to navigate through your entire 
site. 
Setting Up Sitelink Extensions: 
Go to Google Ads: In your account, navigate to the campaign or ad group you 
want to add the sitelinks to. 
Click on Extensions: You’ll find this option in the navigation menu on the left. 
Add a Sitelink Extension: Click on the "plus" button to create a new sitelink. 
You can add multiple sitelinks for each campaign. 
Enter Details: For each sitelink, you’ll need to enter: 
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●​ Link text: The clickable text that will appear under the ad (e.g., "Digital 
Marketing"). 

●​ Final URL: The destination URL for that sitelink. 

Save and Apply: Once you’ve set it up, save and apply your sitelinks. 

 

 

Callout Extensions:(For additional Description) 

Callout Extensions in Google Ads are a type of ad extension that allow you to 
add additional text to your ads. These are short, descriptive snippets that appear 
alongside your standard text ads, providing more details about what you offer. 
 
Setting Up Callout Extensions: 

Navigate to Ads & Extensions 

●​ In the left-hand menu, click on "Ads & Extensions". 
●​ From the top of the page, click on the "Extensions" tab. 
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 Add a New Callout Extension 

●​ Click the blue "+" button (usually at the top left of the page). 
●​ From the dropdown menu, select "Callout extension". 

 Choose Where to Apply the Callout Extension 

●​ You can add callout extensions at different levels: 
○​ Account Level: This will apply the extension to all campaigns within 

your account. 
○​ Campaign Level: Apply callout extensions to a specific campaign. 
○​ Ad Group Level: Apply callout extensions to a particular ad group 

(this is most granular). 
●​ Choose the level that best suits your strategy. 

 Enter Callout Text 

●​ In the pop-up window, you'll be prompted to add your callout text. 
○​ Example Callout Text: "Free Shipping," "24/7 Support," "Exclusive 

Offers," "Easy Returns." 
○​ Each callout can have a maximum of 25 characters. 

●​ Add multiple callouts to test different messaging and highlight various 
features of your product or service. 

Set Callout Extension Status 

●​ You can set your callout extension to either: 
○​ Active: The extension is ready to be used. 
○​ Paused: The extension won't show with your ads. 

●​ Once you're ready, ensure the status is set to Active. 

  

Save the Callout Extension 

●​ After entering your callout text, reviewing the details, and ensuring 
everything looks good, click the "Save" button. 
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Call Extensions: 

Navigate to Ads & Extensions 

●​ In the left-hand menu, click on "Ads & Extensions". 
●​ In the top menu, click on the "Extensions" tab. 

Add a New Call Extension 

●​ Click on the blue "+" button (usually located at the top left of the page). 
●​ From the dropdown, select "Call Extension". 

 Choose Where to Apply the Call Extension 

You can add call extensions at different levels: 

●​ Account Level: This will apply to all campaigns in your account. 
●​ Campaign Level: Apply the call extension to a specific campaign. 
●​ Ad Group Level: Apply it to a specific ad group. 

Choose the level that fits your campaign structure. 
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 Enter Call Extension Details 

●​ Phone Number: Enter the phone number you'd like to display in your ad. 
This is the number users can call directly. 

●​ Country: Choose the country where your business is located. Google Ads 
will format the number based on the country you select. 

 

Save the Call Extension 

After filling out the details, click "Save" to apply the call extension to your 
campaign or ad group. 

 

Quality Score: 
Quality Score is a metric in Google Ads that rates the relevance and quality of 
your keywords, ads, and landing pages on a scale of 1 to 10. A higher Quality 
Score means lower costs per click (CPC) and better ad placements. 
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Factors Affecting Quality Score 

Google calculates Quality Score based on three main factors: 

●​ Expected Click-Through Rate (CTR): How likely users are to click your 
ad. 

●​ Ad Relevance: How well your ad matches user intent. 
●​ Landing Page Experience: How relevant and user-friendly your landing 

page is. 

Ad Rank: 
Ad Rank determines your ad’s position in Google search results and whether it 
will show at all. It is calculated using the formula: 
Adrank score = CPC * QS 
 
Practical Example of Ad Rank Calculation 
 
Three advertisers (A, B, and C) are bidding for the keyword "Online Digital 
Marketing Course" 
Each advertiser has a different Max CPC bid and Quality Score: 
 

Advertiser Max CPC Bid $ QS ( 1- 10) Ad Rank 

A 5.00 6 30 

B 4.00 8 32 

C 6.00 4 24 
 
 

Ad Position Results: 

●​ B wins the top ad position despite bidding less than C because of a 
higher Quality Score (Ad Rank = 32). 

●​ A gets the second position (Ad Rank = 30). 
●​ C gets the third position (Ad Rank = 24) despite having the highest bid. 
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Actual CPC: 
Actual Cost-Per-Click (CPC) is the amount you actually pay when someone 
clicks on your ad. It is usually lower than your Max CPC bid because Google 
Ads uses a second-price auction system. 
 
Formula for Actual CPC: 
Actual CPC + Competitor CPC + 0.01 $ 
 
 

Advertiser Max CPC Bid $ QS  Ad Rank Actual CPC 

A 2 $ 10 20 1.6 $ 

B 4 $ 4 16 3.01 $ 

C 6 $ 2 12 4.01$ 

D 8 $ 1 8 8 $ 
 
“D” has no direct competitor .So Google directly  take his Max CPC is 8. 
 

Conversion Tracking: 
Conversion tracking means Google will track what customer make actions on our 
website.Profitable action done by an user. 
 

Step-by-Step Guide for Setting Up Conversion Tracking in Google Ads 

Navigate to Conversion Settings 

●​ Log in to your Google Ads account. 
●​ Click on Tools & Settings (wrench icon) in the top right corner. 
●​ Under Measurement, select Conversions. 
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Create a New Conversion Action 

●​ Click the + New conversion action button. 
●​ Select Website as the tracking type. 
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Enter Website URL and Scan 

●​ Enter your website URL where conversions occur. 
●​ Click Scan – Google will check if a tag is already present. 

 

 

Add a Conversion Action 

●​ Click Add Conversion Action. 
●​ Set the Conversion Goal (e.g., "Contact Form Submission"). 
●​ Enter the Thank You Page URL (e.g., www.example.com/thank-you). 
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Choose How to Set Up the Conversion 

●​ Automated Setup: Google Ads automatically configures tracking. 
●​ Manual Setup: You manually install the conversion tracking code. 

 

Create a Conversion Action (Manual Setup) 

●​ Click Create conversion action manually. 
●​ Choose Goal & Action Optimization: Select Contact (if tracking form 

submissions). 
●​ Set Click-Through Conversion Window: Define how long after a click a 

conversion is counted (e.g., 30 days). 
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●​ Set View-Through Conversion Window: Define how long a conversion is 
counted after a user sees your ad (without clicking). 

 

Install the Google Tag Manually 

●​ Select Google Tag Setup → Choose Install Manually. 
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●​ Copy the conversion tracking code. 
●​ Paste the code inside the <head> section of your website’s HTML (on all 

pages). 

 

 Confirm Installation & Done! 

●​ Save and Publish changes on your website. 
●​ Click Done in Google Ads. 
●​ Test the setup by visiting the Thank You Page and checking for tracking 

activity in Google Ads. 

Remarketing 
Remarketing in Google Ads is a strategy that allows you to show ads to people 
who have previously visited your website or interacted with your business. It 
helps you re-engage potential customers who didn’t convert on their first visit. 
 
Step-by-Step Guide to Remarketing in Google Ads 

●​ Defining a Remarketing Audience 
●​  Connecting Google Ads to WordPress using Google Tag Manager 
●​  Creating a Remarketing Campaign (Display or Video Network) 

 
1. Remarketing Audience? 
A remarketing audience is a group of users who have previously visited your 
website or interacted with your app but did not complete a desired action 
(purchase, sign-up, etc.). 
Examples of Remarketing Audiences: Website Visitors,Past Customers. 
 
Step-by-Step Guide: Creating a Remarketing Audience in Google Ads 
Access Audience Manager in Google Ads 

●​ Log in to your Google Ads account → Click on the Tools & Settings 
(wrench icon). 

●​ Under Shared Library, select Audience Manager. 
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●​ Click on the blue "+" (plus) button → Select Website Visitors. 

Define Your Audience Segment 

●​ Segment Name → Give your audience a clear name (e.g., “REM - 7pm”). 

 

●​ Segment Members → Choose who should be included in this remarketing 
audience: 

○​ Visitors of a page (e.g., people who viewed a product or service 
page). 

○​ Visitors of a page who also visited another page (e.g., added to 
cart but didn’t complete purchase). 

○​ Visitors of a page who did not visit another page (e.g., visited 
homepage but never checked out). 

○​ Visitors of a page during specific dates (seasonal promotions). 
○​ Visitors of a page with specific tags (advanced tracking). 

Set Audience Rules & Filters 

Refine Actions (Page URL Contains): 
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○​ Click “Actions (Refine Actions)” 
○​ Select Page URL → Contains → Enter the page URL (e.g., 
example.com/cart). 

○​ Use “AND” or “OR” conditions if you need to combine multiple 
pages. 

○​ Example: 
■​ Cart Page: example.com/cart 
■​ Checkout Page (Exclusion): example.com/thank-you 
■​ This means users who visited the cart but didn’t reach the 

thank-you page will be targeted. 

Prefill Options: 

●​ Choose “Include past visitors from the last 30 days” (or adjust to 
60/90/180 days based on business needs). 

●​ If you’re setting up a new remarketing list, select “Start collecting 
visitors from now”. 

 

Create & Save the Segment 
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●​ Click Create Segment to save. 
●​ Your remarketing audience will now start collecting data. 

 

 

 

 

2. Connect Google Ads to WordPress using Google Tag Manager 
Step-by-Step Guide: Connecting Google Ads to a WordPress Website 
Using Google Tag 
To track website visitors and set up remarketing audiences in Google Ads, you 
need to install the Google Ads Tag on your WordPress site. Follow these 
practical steps: 
Access Google Ads Tag in Audience Manager 

1.​Log in to Google Ads → Click the Tools & Settings. 
2.​Under Shared Library, select Audience Manager. 
3.​Click on Your Data Sources . 
4.​Find Google Ads Tag and click Details. 
5.​Under Tag Setup, select Install the Tag Yourself. 
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Add the Tag Manually to WordPress 
Copy the Global Site Tag  from Google Ads. 

 
In WordPress, go to Appearance → Theme File Editor. 
Open header.php and paste the tag inside the <head> section. 
Click Update File to save changes. 
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Verify & Test the Google Ads Tag 

●​ Go back to Google Ads → Audience Manager → Your Data Sources. 
●​ Check the Google Ads Tag Status (it may take a few hours to update). 

 

3. Create a Remarketing Campaign (Display or Video Network) 

Set Up a New Remarketing Campaign 

●​ Go to Google Ads → Campaigns → New Campaign 
●​ Choose a Goal (without goals and guidance) 
●​ Select Display Network (for banner ads) or Video Network (for YouTube 

ads) 

 

●​ Choose Standard Display Campaign or Standard Video Campaign 
●​ Enter your website URL and set a daily budget. 

Select Your Remarketing Audience 

●​ In the Audience Segment section, click on Browse → How they have 
interacted with your business 
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●​ Select Website Visitors (or use a custom audience segment). 

 

●​ Choose your remarketing list (e.g., “Visitors in the Last 30 Days”). 

Set Up Ad Creatives 

 
189 



 

For Display Ads: 

●​ Upload banner ads. 
●​ Write engaging ad copy and include a CTA  

For Video Ads: 

●​ Upload a YouTube video ad and select targeting options. 

 

●​ Adjust bidding strategy (Target CPA or Maximize Conversions). 

 

 Launch the Campaign 

●​ Review your audience, budget, and ads. 
●​ Click Publish and start tracking conversions! 
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Networks of Google Ads 
 

NETWORK TYPE BIDDING WHERE AD 
APPEARS 

TARGETING 

SEARCH TEXT CPC SERP KEYWORDS, 
LOCATION 

DISPLAY IMAGE/VIDEO CPM GDPW/APPS/ 
YOUTUBE 

AGE,GENDER,L
OCATION, 
TOPIC, 
AFFINITY, 
KEYWORDS, 
PLACEMENTS 

VIDEO VIDEOS CPV/CPM YOUTUBE AGE,GENDER,L
OCATION, 
TOPICS, 
AFFINITY, 
PLACEMENTS 

APP IMAGE/TEXT CPI SERP, 
PLAYSTORE, 
GDPW, 
YOUTUBE 

LOCATION 

SHOPPING TEXT/IMAGE/ 
VIDEO 

CPC/CPA SERP FEED/ 
LOCATION 
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 Advanced Search Network Campaign in Google Ads 
An Advanced Search Network Campaign in Google Ads allows you to target 
users actively searching for your products or services using highly optimized 
keywords, audience targeting, ad extensions, and bidding strategies. 

Create a New Search Campaign: 

●​ Log in to Google Ads (ads.google.com) 
●​ Click on Campaigns → + New Campaign 
●​ Choose a Goal (Create a campaign without guidance) 
●​ Select Search Network 

 

●​ Enter your Website URL (if applicable) 
●​ Click Continue 
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Configure Campaign Settings: 

Define Campaign Name & Networks 

●​ Name your campaign 
●​ Uncheck "Include Display Network" to focus only on Search 

 

 Set Locations & Languages 

●​ Select the geographic locations you want to target (country, city, or 
custom radius) 

●​ Choose the language your customers speak 

 Advanced Tip: Click on Location Options → Select Presence: People in or 
regularly in your targeted locations to avoid irrelevant clicks. 
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Set Budget & Bidding Strategy 

Enter your daily budget  

Choose a bidding strategy: Clicks ,Maximum CPC 
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Set Up Your Ad Group & Keywords 

Add Targeted Keywords 

Use Google Keyword Planner to find relevant, high-intent keywords. 

 

Match Types Best Practices: 

●​ Exact Match → [Digital Marketing]  
●​ Phrase Match → "Digital Marketing" 
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Advanced Tip: Add Negative Keywords (e.g.,free, what) to avoid unqualified 
clicks. 

Create Highly Optimized Ads 

Enter 3-5 Headlines (e.g., "Enroll for Free Demo") 
Add 2 Descriptions (e.g., "Welcome to Advanced Digital Marketing Course in 
Telugu") 
Use a Final URL (landing page where users will land) 
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Add Ad Extensions  

●​ Sitelink Extensions  
●​ Callout Extensions  
●​ Structured Snippets  
●​ Call Extensions  
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Review & Launch Your Campaign 

●​ Double-check settings, keywords, and ads 
●​ Click Publish to launch your campaign 
●​ Monitor performance in Google Ads → Reports → Search Terms 

 

Display Network Campaign in Google Ads 

Create a New Display Campaign: 

Click on Campaigns → + New Campaign: 

●​ Choose Create a Campaign without guidance (this option lets you 
customize your campaign fully). 

Select Display Network: 

●​ Choose the Display Network option to focus on visual ad placements 
across websites, apps, and Google Display Network. 
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Enter Your Website URL: 

●​ Provide your website URL if applicable. 
●​ Click Continue. 

Configure Campaign Settings: 

Define Campaign Name & Networks: 

Name your campaign. 
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Set Locations & Languages: 

●​ Target Locations: Choose the geographic regions (country, city, or custom 
radius). 

●​ Target Languages: Select the language your audience speaks. 
●​ Advanced Tip: Click on Location Options → Presence to target people 

who are in or regularly in your locations. This helps avoid irrelevant clicks. 

 

Set Budget & Bidding Strategy: 

●​ Set Daily Budget: Determine how much you're willing to spend each day. 
●​ Choose a Bidding Strategy: 

○​ Viewable impressions 
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Set Up Your Ad Group & Targeting: 

Define Your Ad Group: 

●​ Name your ad group and set targeting criteria. 

Target Audience & Placements: 

●​ Choose how you want to target your audience: 
○​ Demographic Targeting: Age, gender, parental status, etc. 
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○​ Audience Targeting: Interest-based, affinity, in-market segments. 
○​ Placements: Choose specific websites or apps where you want your 

ads to appear. 

 

●​ Advanced Tip: You can use Topic Targeting to display ads on pages 
related to specific subjects. 
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Create and Upload Ads: 

●​ Responsive Display Ads: Add multiple images, logos, and headlines, and 
Google will automatically create the best-performing ad combinations. 

○​ Headlines: Up to 5 headlines (e.g., "24/7 support"). 

 

○​ Descriptions: Up to 5 descriptions (e.g., " Institute for Providing 
Digital Marketing Course in Telugu. Get Trained by Industry Experts"). 

○​ Images & Logos: Upload visually appealing assets (ensure images 
are high-quality and optimized for display). 

○​ Final URL: Enter the landing page where users will land after clicking 
the ad. 
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Ad Formats: 

●​ Static Image Ads: Upload ready-to-use image banners. 

Add Ad Extensions (Optional): 

●​ Sitelink Extensions: Links to specific pages on your website. 
●​ Callout Extensions: Highlight additional benefits or offers. 
●​ Structured Snippets: Provide more detailed information about your 

offerings. 
●​ Call Extensions: Add phone numbers for direct calls. 

Review & Launch Your Campaign: 

●​ Double-Check Campaign Settings: 
○​ Review your targeting, budget, and ads to ensure everything is set up 

correctly. 
●​ Launch Campaign: 

○​ Once satisfied, click Publish to launch your Display Network 
campaign. 
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Video Network Campaign in Google Ads 

Create a New Video Campaign: 

Click on Campaigns → + New Campaign: 

●​ Select Create a Campaign without guidance to have full control over your 
settings. 

Select Video Campaign: 

●​ Choose the Video Campaign type. 
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Enter Your Website URL: 

●​ If applicable, enter your website URL and click Continue. 

Configure Campaign Settings: 

Define Campaign Name & Networks: 

●​ Name your campaign for easy identification. 
●​ Choose Networks: 

○​ YouTube Videos: Display your video ads on YouTube. 
○​ YouTube Search Results: Show ads in search results on YouTube 

when users search for relevant content. 
○​ Video Partners on the Display Network: Extend your reach to video 

content on partner sites across the Google Display Network. 
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Set Locations & Languages: 

●​ Target Locations: Choose the countries, cities, or regions where your 
target audience resides. 

●​ Target Languages: Select the language(s) your audience speaks. 
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●​ Advanced Tip: Click on Location Options → Presence to target people 
physically in or regularly present in the selected locations. This helps avoid 
irrelevant views. 

 

Set Budget & Bidding Strategy: 

●​ Set Daily Budget: Define the amount you are willing to spend per day on 
your video campaign. 

●​ Choose a Bidding Strategy: CPV (Cost per View): Pay for each view or 
interaction with your ad. 
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Set Up Your Ad Group & Targeting: 

Define Your Ad Group: 

Name your ad group and specify your audience and targeting options. 

Target Audience & Placement: 

●​ Choose how you want to target your video campaign audience: 
○​ Demographic Targeting: Age, gender, parental status, and 

household income. 
○​ Audience Targeting: Interest-based, in-market segments (e.g., 

people actively looking for products like yours), remarketing (target 
people who’ve interacted with your previous videos or website). 

○​ Keywords: Target users based on keywords that relate to your video 
content. 

○​ Topics: Choose topics relevant to your video content (e.g.,Education). 
○​ Placements: Choose specific YouTube channels, videos, or websites 

where you want your video to appear. 

Advanced Tip: Use Remarketing to target people who have previously 
interacted with your business or watched your videos. 

209 



 

 

Create Your Video Ad: 

Video Format: Upload your video (YouTube link or directly from your computer) 
for the ad. 
Ad Type: Choose the type of video ad you want: 

●​ Skippable In-stream Ads: Viewers can skip the ad after 5 seconds. 
Charges only occur when viewers watch 30 seconds or interact with the ad. 

●​ Non-Skippable In-stream Ads: Viewers cannot skip. These ads typically 
last 15-20 seconds and are billed based on CPM (cost per thousand 
impressions). 

●​ Bumper Ads: 6-second ads that cannot be skipped, ideal for building brand 
awareness. 

●​ Outstream Ads: Ads that appear on partner sites or apps outside of 
YouTube. 
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Video Ad Settings: 

●​ Video URL: If using YouTube, paste the URL of the video you want to 
advertise. 

●​ Call to Action (CTA): Add a CTA like "Learn More," "Shop Now," or 
"Subscribe." 

●​ Display URL: Ensure the URL shown on the ad is relevant to your video. 
●​ Final URL: The landing page users will land on after interacting with the ad. 
●​ Ad Copy: Write compelling ad copy that encourages viewers to take action. 

 

Review & Launch Your Campaign: 

1.​Double-Check Campaign Settings: 
○​ Review your video ad, targeting, bidding strategy, and budget. 

2.​Launch Campaign: 
○​ Once everything is configured, click Publish to launch your video 

campaign. 
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Mobile Network Campaign in Google Ads 

Create a New Mobile Network Campaign: 

Click on Campaigns → + New Campaign: 

●​ Select Create a Campaign without guidance to have full control over your 
campaign settings. 

Select Campaign Type 

Enter Your Website URL: 

●​ Enter the URL of the landing page you want to promote and click Continue. 

Select Campaign Type: 

●​ Choose App Campaign. 
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●​ Google Ads will automatically use a variety of formats to promote your app, 
including search, display, YouTube, and Google Play, across Google’s 
network. 

●​ Select Install App if your goal is to increase app downloads, or 
Engagement with App if you want to encourage in-app actions from 
existing users. 

 

Enter Your App Information: 

●​ Provide your app’s name and URL (App Store or Google Play Store URL). 
●​ Choose the correct platform (iOS or Android) based on your app. 
●​ Click Continue. 
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Configure Campaign Settings: 

Define Campaign Name & Bidding: 

●​ Name your campaign for easy identification (e.g., “App Install Campaign”). 
●​ Choose a Bidding Strategy: CPA (cost per installation) 

Set Budget & Locations: 
Set Daily Budget: Specify how much you want to spend daily on your app 
promotion campaign. 

 
 
Target Locations: Choose the locations where you want to promote your app 
(country, region, city, or custom radius). 
Target Languages: Choose the languages your app users speak. 
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Target Devices: 

●​ You can target users on mobile devices (smartphones or tablets) for your 
app campaign. 

●​ Advanced Tip: If you only want to target iOS or Android devices, ensure to 
adjust the targeting accordingly in the settings. 

 

Set Up Your Ad Group & Assets: 

Create Ad Assets: 

●​ For App Campaigns, Google Ads uses a variety of assets to create ads 
automatically across different formats (search ads, display ads, YouTube 
video ads, etc.). You will need to provide: 

Text Assets: 3-5 headlines and 2-5 descriptions. These will be used to create 
your ads across the network. 

●​ Example Headline: "Download Our App Now" 
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●​ Example Description: "Get exclusive offers and save on every purchase. 
Install now!" 

Image Assets: Upload images that will be used in your display ads. 
Video Assets (Optional): You can upload videos for YouTube and display ads. 
Videos typically improve app engagement, so it’s beneficial to add them. 
App Store Links: Add your app’s download links for both the Google Play Store 
and the Apple App Store. 

 
 

Add Call-to-Action (CTA): 

●​ Google Ads will automatically choose a relevant CTA (e.g., “Install Now” or 
“Learn More”) based on the goal of the campaign. 

Review & Launch Your Campaign: 

1.​Double-Check Campaign Settings: 
○​ Review all your ad assets, budget, bidding strategy, and targeting 

settings. Make sure all the information is correct before launching. 
2.​Launch Campaign: 

○​ Once everything looks good, click Publish to launch your App 
Network campaign. 
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Shopping Network Campaign in Google Ads 
Step 1: Set Up Your E-commerce Website 

Ensure your website is e-commerce ready: Your site should have a secure 
checkout process (SSL certification), clear product pages, and easy 
navigation for users. 
Prepare your product data: Collect the necessary information about your 
products (title, description, price, image, availability, etc.) that will be used in your 
Google Merchant Center feed. 
 

Step 2: Set Up Google Merchant Center (GMC) Feed 

Create a Google Merchant Center Account: 

●​ Go to Google Merchant Center and create an account if you don’t have one 
already. 

 

●​ Enter your website URL, business information, and country. 
●​ Verify and claim your website within GMC to ensure your site is linked to 

your Merchant Center account. 
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Set Up Your Product Feed: 

●​ Product Feed: Upload a file containing all your product details (product 
IDs, titles, descriptions, prices, images, availability, etc.). You can upload 
this feed manually, or set up an automatic feed using a Google Sheets 
template or API. 

 Feed Rules: Make sure your product feed adheres to Google’s policies. For     
example: 

●​ Title: Include relevant keywords without keyword stuffing. 
●​ Description: Provide clear, concise, and accurate descriptions of the 

products. 
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●​ Images: Use high-quality images that meet Google's requirements. 
●​ Price & Availability: Ensure the price and availability are accurate and 

updated regularly. 
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Feed Format Options: 

●​ You can upload feeds in formats like CSV, TSV, or XML. 
●​ Google also provides an automated feed option if you have an integration 

system with your e-commerce platform (e.g., Shopify, WooCommerce, 
BigCommerce). 

 

Review & Submit Your Feed: 

●​ After uploading, Google will process your feed. Ensure there are no errors 
in your feed by checking the Diagnostics tab in Google Merchant Center. 

●​ Advanced Tip: Set up automatic feed refresh to keep your product data 
up-to-date with Google Merchant Center. 

Step 3: Link Google Ads and Google Merchant Center (GMC) 

Go to Google Ads Account: 

●​ Log in to your Google Ads account. 
●​ Navigate to Tools & Settings → Linked Accounts. 

Link Google Merchant Center to Google Ads: 
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●​ Under Linked Accounts, select Google Merchant Center. 
●​ Click + to link your Merchant Center account to Google Ads. 
●​ Verify the link by selecting your Merchant Center account from the list. 
●​ Ensure you’ve selected the correct Google Merchant Center account 

associated with your e-commerce store. 

 

Step 4: Create a Shopping Campaign in Google Ads 

Click on Campaigns → + New Campaign: 

●​ Choose Create a Campaign without guidance for full control over your 
campaign settings. 

●​ Alternatively, you can select Sales as the goal to focus on eCommerce 
conversions. 

Select Campaign Type: 

●​ Choose Shopping as the campaign type. 
●​ This type of campaign automatically uses your product feed to create ads 

for your online store, which will appear in Google Shopping, Google Search, 
and the Display Network. 
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Configure Campaign Settings: 

Define Campaign Name & Bidding: 

●​ Name your campaign 
●​ Choose Bidding Strategy: CPC(cost per click) Converts CPA(cost per 

acquisition) 

Set Locations & Languages: 

●​ Target Locations: Choose the countries, cities, or regions where you 
want to show your ads. 

●​ Target Languages: Select the languages your customers speak. 
●​ Advanced Tip: Use Location Options → Presence to target people who are 

physically in or regularly in the selected locations to avoid irrelevant clicks. 
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Set Budget & Schedule: 

Set Daily Budget: Define how much you’re willing to spend each day on the 
campaign. 

Set Start and End Dates: If applicable, set a campaign start and end date to 
control when your campaign runs. 
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Create Product Groups: 

●​ Organize your products into product groups. You can group them by 
categories, brands, or custom labels. 

●​ For example: 
○​ Product Group 1: Women’s Shoes 
○​ Product Group 2: Men’s Clothing 
○​ Custom Labels: Best Sellers, Seasonal Products 

 

Launch Your Campaign: 

●​ Once everything is set up, click Publish to launch your Shopping 
Campaign. 

Step 5: Handling Irrelevant Keywords & Feed Issues 
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Performance max Campaign in Google Ads 

Create a New Video Campaign: 

Create a New Campaign: 

●​ Click on the Campaigns tab on the left sidebar, then click the + New 
Campaign button. 

●​ Select Create a Campaign without guidance to have full control over your 
campaign settings. 

Select Performance Max as the Campaign Type: 

●​ Choose Performance Max to access Google’s entire inventory (Search, 
Display, YouTube, Gmail, Discover, and Maps). 

●​ Click Continue to proceed. 
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Configure Campaign Settings 

Define Campaign Name & Networks: 

●​ Name your Performance Max campaign appropriately. 

Set Locations & Languages: 

●​ Target Locations: Select geographic regions (country, city, or custom 
radius). 

●​ Target Languages: Choose the languages your audience speaks. 
●​ Advanced Tip: Click on Location Options → Presence to target users 

who are in or regularly in the selected locations. 

Set Budget & Bidding Strategy: 

●​ Daily Budget: Decide how much you want to spend per day. 
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Choose a Bidding Strategy: 

●​ Maximize Conversions: If your goal is more leads or purchases. 

 

Set Up Your Asset Group & Targeting 

Create an Asset Group: 

●​ Name Your Asset Group based on targeting strategy 
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Upload Various Ad Assets: 

●​ Headlines: Up to 5 headlines (e.g., "Limited-Time Offer, Buy Now!"). 
●​ Descriptions: Up to 5 descriptions (e.g., "Get 20% off on your first order."). 
●​ Images: Upload high-quality images optimized for different placements. 
●​ Logos: Ensure logos are clear and branded. 
●​ Videos: If no video is provided, Google may auto-generate one. 
●​ CTA (Call-to-Action): Choose from preset options (e.g., "Shop Now," "Sign 

Up"). 

Final URL & Ad Extensions 

Set the Final URL: 

●​ Provide the landing page URL where users will land after clicking your ad. 
●​ Enable Final URL Expansion to allow Google to direct traffic to the 

best-performing landing pages. 
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Review & Launch Your Campaign 

Double-Check Campaign Settings: 

○​ Review targeting, budget, asset groups, and audience signals to 
ensure everything is set up correctly. 

Launch Your Campaign: 

○​ Click Publish to activate your Performance Max Campaign. 

Portfolio Bidding Strategies in Google Ads 
Portfolio bidding strategies in Google Ads allow advertisers to manage multiple 
campaigns, ad groups, and keywords under a single automated bidding strategy. 

Types of Portfolio Bidding Strategies in Google Ads 
●​ Target CPA (Cost Per Acquisition) - – Get More Conversions at a Fixed 

Cost 
●​ Target ROAS (Return on Ad Spend) – Focus on Revenue Maximization 
●​ Maximize Conversions – Get the Most Conversions Possible 
●​ Maximize Conversion Value – Prioritize High-Value Sales 
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●​ Maximize Clicks – Drive More Traffic to Your Website 
 
How to Set Up Portfolio Bidding Strategies in Google Ads 
(Step-by-Step Guide) 
Step 1: Go to the Bid Strategies Section 

●​ Click on "Tools and Settings"  
●​ Under the "Budget and Bidding" section, select "Bid Strategies". 

Step 2: Create a New Portfolio Bidding Strategy 
●​ Click on the blue "+" (plus) button to create a new bid strategy. 
●​  Choose the bidding strategy that aligns with your goals. 

Example: 

●​ If you want to get more conversions at a fixed cost per acquisition, 
select "Target CPA". 

Step 3: Configure Target CPA (Cost Per Acquisition) 
●​ Name your strategy → Example: "Lead Generation - Target 
CPA $20" 

●​  Set your Target CPA → Example: Enter $20 per conversion (lead or 
purchase). 

●​  Select campaigns to apply this strategy. 

Step 4: Save and Apply to Campaigns 

●​ After selecting campaigns, click "Save". 
●​  The portfolio bid strategy is now applied to the selected campaigns. 
●​  Google Ads will automatically optimize bids to get leads at or below the 

target CPA. 
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What is GCLID (Google Click Identifier) in Google Ads? 
GCLID (Google Click Identifier) is a unique tracking parameter added to 
URLs when someone clicks on a Google Ads ad. It helps track user interactions 
and measure campaign performance in Google Ads, Google Analytics, and 
CRM systems. 

When auto-tagging is enabled in Google Ads, GCLID is automatically appended 
to the landing page URL. 

 

What are Dynamic Search Ads (DSA) in Google Ads? 
Dynamic Search Ads (DSA) are a type of automated ad format in Google Ads 
that dynamically generates headlines and landing pages based on a website’s 
content. Instead of manually selecting keywords, Google scans your website 
and automatically matches user search queries to relevant pages on your site. 

 How to Set Up Dynamic Search Ads (DSA) in Google Ads 
 Create a New Search Campaign 

●​ Log in to Google Ads (ads.google.com) 
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●​ Click on Campaigns → + New Campaign 
●​ Choose a Goal (Create a campaign without guidance) 
●​ Select Search Network 
●​ Enter your Website URL (if applicable) 
●​ Click Continue 

 

 

Configure Campaign Settings: 

Define Campaign Name & Networks 

●​ Name your campaign 

 Set Locations & Languages 

●​ Select the geographic locations you want to target (country, city, or 
custom radius) 

●​ Choose the language your customers speak 
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Set Budget & Bidding Strategy 

Enter your daily budget  

Choose a bidding strategy: Clicks  
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Keyword and asset Generation 

Enter your website url -> Generate. 
In this Automatically Ad group will create according to their website content 

 

Review & Launch Your Campaign 
 

Call Ads in Google Ads? 
Call Ads in Google Ads are a type of ad format designed to encourage users to 
call your business directly. Instead of clicking on a website link, users tap the ad 
to call your business from their mobile devices. 
 
How to Set Up Call Ads in Google Ads 

●​ Log in to Google Ads (ads.google.com) 
●​ Click on Campaigns → + New Campaign 
●​ Choose a Goal (Create a campaign without guidance) 
●​ Select Search Network 
●​ Enter your Website URL (if applicable) 
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●​ Click Continue 

Configure Campaign Settings: 

Define Campaign Name & Networks 

●​ Name your campaign 

 Set Locations & Languages 

●​ Select the geographic locations you want to target (country, city, or 
custom radius) 

●​ Choose the language your customers speak 

Set Budget & Bidding Strategy 

Enter your daily budget  

Choose a bidding strategy: Clicks  

In Adcopy select call ad 

 

Write Your Call Ad 
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 Example Call Ad: 

●​ Phone Number: (123) 456-7890 
●​ Business Name: "Mike’s Plumbing Services" 
●​ Headline 1: "24/7 Emergency Plumbing - Call Now" 
●​ Headline 2: "Fast Service & Affordable Rates" 
●​ Description: "Licensed plumbers available now. No hidden fees. Call for a 

free estimate!" 
●​ Final URL (Optional): www.example.com 

 

Save & Launch Your Call Ads 

●​  Click "Save and Continue".​
 Google Ads will now show your Call Ads when users search for relevant 
keywords. 
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SOCIAL MEDIA 

Social Media Optimization (SMO) 
Social Media Optimization (SMO) is the process of improving your social media 
profiles, content, and interactions to increase brand awareness, engagement, 
and traffic. It involves using strategies that make your social media presence 
more effective and visible to the target audience. 
Social Media Optimization (SMO) is Organic process. 

What is the EdgeRank Algorithm in Social Media Optimization? 
EdgeRank is Facebook’s algorithm used to determine which posts appear in a 
user's News Feed. It prioritizes content based on relevance, engagement, and 
interactions, ensuring that users see posts they are most likely to engage with. 
Although Facebook has evolved its ranking system, the principles of EdgeRank 
still influence content visibility. 

How Does the EdgeRank Algorithm Work? 

The algorithm considers three main factors: 

●​ Affinity (User Interaction) 
○​ Measures the relationship between the user and the content creator. 
○​ More interactions (likes, shares, comments) = Higher affinity = More 

visibility. 
●​ Weight (Engagement Type) 

○​ Different types of interactions have different values. 
○​ Comments & shares > Likes > Clicks (More valuable interactions push 

content higher). 
●​ Time Decay (Recency) 

○​ Newer posts are given more priority over older ones. 
○​ Posts lose visibility over time unless they continue getting 

engagement. 
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What is the 80/20 Rule in Social Media Optimization? 

The 80/20 Rule in Social Media Optimization (SMO) suggests that 80% of your 
content should provide value to your audience (educational, entertaining, or 
engaging), while only 20% should be promotional (directly advertising products 
or services).  

Push and Pull techniques in Social Media Optimization (SMO) 
Push Technique: 
This method involves actively pushing content to users, often through paid ads, 
direct promotions, or influencer collaborations. 
Examples of Push Technique: 
Paid Advertisements – Running Facebook, Instagram, or YouTube ads to show 
content to a targeted audience. 
Sponsored Posts – Collaborating with influencers or brands to promote a 
product. 
Email Marketing – Sending newsletters or promotions to social media 
subscribers. 
 
Pull Technique : 
This method attracts audiences naturally through engaging, valuable, and 
shareable content. Instead of actively promoting, it relies on search optimization, 
user-generated content, and engagement strategies. 

Examples of Pull Technique: 

●​ SEO Optimized Blog Posts – Writing informative articles with keywords so 
they appear in Google search results. 

●​ Engaging Social Media Content – Creating viral videos, memes, and 
interactive polls. 

●​ Hashtag Campaigns – Encouraging users to share content using a 
specific hashtag. 
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A/B Testing in Social Media Optimization (SMO) 

A/B testing (also called split testing) is a method used in Social Media 
Optimization (SMO) to compare two versions of content (A & B) to determine 
which one performs better. 

 

Social Media Marketing (SMM) 
Social Media Marketing (SMM) is the process of using social media platforms like 
Facebook, Instagram, Twitter, LinkedIn,  and others to promote a brand, product, 
or service. It involves content creation, audience engagement, paid advertising, 
and analytics to drive brand awareness, website traffic, and sales. 

Facebook: 
Facebook is one of the most powerful platforms for social media marketing due 
to its large user base and advanced advertising features. Businesses use 
Facebook to promote their brand, connect with customers, and drive sales 
through organic and paid marketing strategies. 
Key Features of Facebook for Marketing: 

●​ Facebook Pages 
A Facebook Page acts as a business profile where brands can share 
updates, post content, and interact with customers. 

●​ Facebook Groups 
●​ Facebook Marketplace 
●​ Facebook Stories & Reels 
●​ Facebook Messenger 

Instagram: 
Instagram is one of the most popular social media platforms for marketing, 
especially for brands targeting younger audiences. It focuses on visual content, 
such as images and videos, making it perfect for businesses storytelling, and 
engagement. 
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Key Features of Instagram for Marketing 

●​ Instagram Business Profile 
●​ Instagram Posts (Images & Carousels) 
●​ Instagram Stories 
●​ Instagram Reels 
●​ Instagram Live 
●​ Instagram Shopping 
●​ Instagram Highlights 
●​ Instagram Ads (Paid Promotion) 
●​ Instagram Hashtags & SEO 

LinkedIn: 

LinkedIn is the world’s largest professional networking platform, making it an 
ideal space for B2B (Business-to-Business) marketing, professional branding, 
and corporate engagement. It helps businesses connect with industry leaders, 
recruit talent, share insightful content, and generate high-quality leads. 
Key Features of LinkedIn for Marketing 

●​ LinkedIn Business Page 
●​ LinkedIn Posts (Text, Images, and Videos) 
●​ LinkedIn Articles 
●​ LinkedIn Ads (Paid Advertising) 
●​ LinkedIn Groups 
●​ LinkedIn Live 

Twitter: 
Twitter (now rebranded as X) is a fast-paced social media platform that allows 
businesses to engage with audiences in real-time, share updates, and participate 
in trending conversations. It is widely used for brand awareness, customer 
service, and industry discussions.It is also called as micro blogging site with only 
280 characters. 
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Key Features of Twitter for Marketing 

●​ Tweets (Short-Form Content) 
●​ Twitter Threads 
●​ Twitter Hashtags (#) 
●​ Twitter Trends & Trending Topics 
●​ Twitter Ads (Paid Promotions) 
●​ Twitter Polls 

 

How to Create a Facebook Page – Step-by-Step Guide 
Creating a Facebook Business Page is free and helps businesses, brands, and 
public figures connect with their audience. Follow these practical steps to create 
your page: 
 
Step 1: Log in to Facebook 
Go to Facebook.com and log in with your personal account. 
 Note: You must have a personal Facebook account to create a business page. 
 
Step 2: Go to Page Creation 

●​ Click on the Menu (≡) in the top-right corner. 
●​  Select "Pages" from the options. 
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●​  Click on "Create New Page." 

Step 3: Enter Basic Page Information 
You'll need to fill in: 

●​ Page Name: 
●​ Category: 
●​ Description: 
●​ Click ‘Create Page’ when done. 
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Step 4: Add Profile & Cover Photos 
Step 5: Add Contact & Business Details 

 
 

What is Meta Business Suite in Facebook? 
Meta Business Suite is a free tool by Meta (Facebook’s parent company) that 
helps businesses manage their Facebook and Instagram accounts in one place. 
It allows users to create and schedule posts, respond to messages, view 
insights, and run ads efficiently. 

How to Use Meta Business Suite (Step-by-Step Guide) 
Step 1: Access Meta Business Suite 

●​ Go to business.facebook.com 
●​  Log in with your Facebook account 
●​  Select the Facebook Page or Instagram Account you want to manage and 

click on Professional Dashboard. 
Features & Practical Uses of Meta Business Suite: 
Home Dashboard – Quick Overview 

●​ Shows notifications, insights, and latest activity on Facebook & Instagram 
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●​ Displays recent comments, messages, and post performance 
Content – Create & Schedule Posts 

●​ Create and schedule Posts, Stories, and Reels for both Facebook & 
Instagram 

●​ Save time by planning content in advance 
 Inbox – Manage Messages & Comments 
     Reply to Facebook and Instagram messages from one inbox 
Insights & Analytics – Track Performance 

●​ Provides data on reach, engagement, likes, and followers 
●​ Shows top-performing posts and best posting times 

Linked accounts 
Linking accounts in Meta Business Suite allows businesses to manage their 
Facebook Pages, Instagram accounts, and WhatsApp Business accounts in one 
place.  
Planner 
The Planner in Meta Business Suite is a content scheduling and management 
tool that helps businesses plan, create, and schedule posts, stories, and reels for 
Facebook and Instagram in one place. 
 

How to Access Facebook Ads Manager – Step-by-Step 
Guide 
Facebook Ads Manager is the platform where businesses can create, manage, 
and analyze their Facebook & Instagram ad campaigns. It provides tools for 
targeting audiences, setting budgets, and tracking performance. 

Step 1: Log in to Facebook 

●​  Go to Facebook.com 

●​  Log in with your personal account (must be linked to a business 
page) 

Step 2: Open Facebook Ads Manager 
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●​ Direct Link: Visit Facebook Ads Manager​
 Alternative Method: 

●​ Click the Menu (≡) at the top-right corner of Facebook 
●​ Select “Ads Manager” under the Professional Tools section 

Step 3: Select the Correct Business Account 

●​  If you manage multiple accounts, click the drop-down menu at the top left 
●​ Choose the correct business account you want to manage ads for 

Step 4: Explore Facebook Ads Manager Dashboard 

 Key sections in Ads Manager: 

●​ Campaigns Tab → View & create advertising campaigns 
●​ Ad Sets Tab → Manage audience, budget, and placements 
●​ Ads Tab → Create, edit, and monitor individual ads 
●​ Insights & Reports → Analyze ad performance 

 

How to give access in facebook ads account access 

Step 1: Open Facebook Ads Manager 

 Go to Facebook Ads Manager​
 Click the  ⚙ (Settings) at the bottom left 

Step 2: Go to "Ad Account Settings" 

 Find "Ad Account Roles"​
 Click "Add a Person" 

Step 3: Assign Permissions & Send Invite 

 Enter the person’s Facebook email​
 Select their Role (Admin, Advertiser, or Analyst)​
 Click "Confirm" 
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 The person will get a notification and must accept the invite to gain access. 

How to Add Budget in Facebook Ads Account 
(Step-by-Step Guide) 

Step 1: Open Facebook Ads Manager 

 Go to Facebook Ads Manager​
 Click the ☰ (Menu) button in the top left corner​
 Select "Billing" 

Step 2: Go to Payment Settings 

 Click on "Payment Settings"​
 You will see the current payment method and billing details 

Step 3: Add or Update Payment Method 

 Click "Add Payment Method"​
 Choose a payment option: 

●​ Credit/Debit Card (Visa, Mastercard, AMEX, etc.) 
●​ PayPal 
●​ Online Banking (Available in some regions) 

 Enter your billing details and click "Save" 
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Facebook Account structure 

 

How to create campaign in facebook ads manager 

Step 1: Log in to Facebook Ads Manager 

●​ Go to Facebook Ads Manager 
●​ Log in to your Facebook Business account. 

​

Step 2: Click "Create" to Start a New Campaign 

●​ In the Campaigns tab, click the green “+ Create” button. 
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Step 3: Choose Your Campaign Objective 

Facebook offers different objectives. Select one based on your goal: 

●​ Awareness: Brand Awareness, Reach 
●​ Consideration: Traffic, Engagement, App Installs, Video Views, Lead 

Generation, Messages 
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Step 4: Name Your Campaign & Set Budget 

Campaign Name: Enter a name . 

 

Campaign Budget: 

●​ Daily Budget: Set a daily limit. 
●​ Lifetime Budget: Total spend for the campaign duration. 
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A/B Testing (Optional): Enable if you want to test multiple versions. 

Click Next to continue. 

Step 5: Set Up Your Ad Set 

 

●​ Traffic Destination: Choose Website, App, Messenger, or WhatsApp. 
●​ Audience Targeting: 

○​ Custom Audiences: Upload email lists or use website visitors. 
○​ Location: Target a country, city, or specific area. 
○​ Age & Gender: Select based on your audience. 
○​ Interests & Behavior: Choose relevant interests (e.g., "Digital 

Marketing" if targeting marketers). 
●​ Placements: 

○​ Automatic Placements (Recommended) 
○​ Manual Placements: Choose Facebook Feed, Instagram, Stories, etc. 
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Click Next to continue. 

Step 6: Create Your Ad 

 

●​ Format: Choose Single Image, Carousel, or Video Ad. 
●​ Media: Upload an image or video. 
●​ Primary Text: Write an engaging ad copy. 
●​ Headline: Short and catchy (e.g., "Boost Your Website Traffic Today!"). 
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●​ Call to Action (CTA): Choose a CTA button (e.g., "Learn More" or "Sign 
Up"). 

●​ Destination URL: Enter your website link. 

Preview your ad in different placements. 

 

Step 7: Publish Your Ad 

●​ Click Publish to submit your campaign. 
●​ Facebook will review your ad before approval (usually within a few hours). 

Step 8: Monitor & Optimize 

●​ Go to Ads Manager Dashboard. 
●​ Track performance: CTR (Click-through rate), CPC (Cost per Click), 

Conversions. 
●​ Make changes if needed (adjust targeting, budget, or creatives). 
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Lead Generation campaign in facebook ads manager 
Step 1: Log in to Facebook Ads Manager 

●​ Go to Facebook Ads Manager 
●​ Log in to your Facebook Business account. 

Step 2: Click "Create" to Start a New Campaign 

●​ In the Campaigns tab, click the green “+ Create” button. 

Step 3: Choose "Lead Generation" as Your Campaign Objective 

Facebook provides different objectives. Select "Lead Generation" because you 
want to collect leads (e.g., emails, phone numbers). 

Click Continue. 
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Step 4: Set Up Your Campaign 

●​ Campaign Name: Enter a name  

 

●​ Special Ad Category: Select if required  
●​ A/B Testing (Optional): Enable if you want to test different versions. 

Step 5: Set Up Your Ad Set 

●​ Ad Set Name: Choose a name (e.g., "Lead Form - Target Audience 1"). 
●​ Facebook Page: Select your business page. 
●​ Instant Form: Facebook will collect leads directly within Facebook (users 

don’t need to leave the platform) 
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●​ Budget & Schedule: 
○​ Choose Daily Budget (e.g., $10/day) or Lifetime Budget (e.g., $300 for 

30 days). 
○​ Set a Start and End Date (if needed). 

●​ Audience Targeting: 
○​ Custom Audiences: Upload existing leads or use website visitors. 
○​ Location: Select the target country, city, or radius around a specific 

location. 
○​ Age & Gender: Define the age range and gender of your audience. 
○​ Detailed Targeting: Choose interests, behaviors, or job titles relevant 

to your audience. 
●​ Placements: 

○​ Automatic Placements (Recommended) 
○​ Manual Placements: Choose where your ads will appear (e.g., 

Facebook Feed, Instagram, Stories). 

Click Next. 
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Step 6: Create Your Ad 

●​ Ad Name: Give your ad a name (e.g., "Lead Ad - Free Ebook"). 

 

●​ Format: Choose Single Image, Carousel, or Video Ad. 
●​ Media: Upload an image or video (Recommended size: 1080x1080px). 
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●​ Primary Text: Write an engaging ad copy (e.g., "Want more marketing tips? 
Download our free guide!"). 

●​ Headline: Short and compelling (e.g., "Get Your Free Guide Now"). 
●​ Call to Action (CTA): Select “Sign Up”, “Get Offer”, or “Learn More”. 

Step 7: Create a Lead Form 

●​ Click Create Form. 
●​ Choose Form Type 

Add an Intro Section (Optional) 

●​ Background Image: Upload a 1200x628px image (e.g., a banner with your 
brand logo or product image). 

●​ Greeting Headline: Write a short, catchy greeting (e.g., "Get Your Free 
Digital Marketing Ebook!"). 

●​ Description: Briefly explain the offer (e.g., "Fill in your details to download 
our exclusive guide on digital marketing strategies."). Click Next. 

Add Questions to Collect Leads 

●​ By default, Facebook collects: 
○​ Full Name 
○​ Email 
○​ Phone Number 

●​ You can add custom questions (optional) 
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Add Privacy Policy 

●​ Facebook requires a privacy policy link. 
●​ Paste the URL of your privacy policy  page 
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Customize the Thank You Screen 

●​ Headline: (e.g., "Thank You! Your Free Guide is on the Way!") 
●​ Description: (e.g., "Check your email for the download link. Our team will 

contact you soon!"). 
●​ Call-to-Action Button (Choose one): 

○​ Visit Website (Enter your website URL) 
○​ Call Business (Enter a phone number) 
○​ Download (Provide a direct link to your ebook or resource) 

Click Finish. 

●​ Click Publish to submit for approval. 

 

Step 8: Publish Your Ad 

●​ Review all settings. 
●​ Click Publish to submit the campaign. 
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How to create Business portfolio account in meta 
Business suite in facebook 

Step 1: Access Meta Business Suite 

●​ Log in to Facebook 
○​ Go to Facebook and log in with your personal account. 

●​ Open Meta Business Suite 
○​ Visit Meta Business Suite. 
○​ If you're using a mobile device, download the Meta Business Suite 

App from the App Store or Google Play. 
●​ Click on "Create Account" 

○​ If you're new to Meta Business Suite, it will prompt you to create a 
Business Portfolio Account. 

Step 2: Set Up Your Business Portfolio Account 

●​ Enter Business Details 
○​ Business Name: Use your official business name. 
○​ Your Name & Email: Use an email linked to your business. 

●​ Connect Your Facebook Page 
○​ If you have a Facebook Business Page, connect it. 
○​ If you don’t have one, create a new Facebook Page. 
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Step 3: Add Business Assets 

Once your account is set up, you can add and manage the following: 

●​ Pages 
○​ Click on "Accounts" → "Pages" → Add your Facebook Page. 

●​ Ad Accounts 
○​ If you run ads, go to "Accounts" → "Ad Accounts" and create or 

add an ad account. 
●​ Instagram Account 

○​ Connect your Instagram under "Accounts" → "Instagram 
Accounts". 

●​ People & Roles 
○​ Add team members under "People" and assign roles like Admin, 

Editor, or Advertiser. 
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Step 4: Optimize Your Portfolio 

       Update Business Info 

○​ Go to "Business Settings" → "Business Info" and add your: 
■​ Website 
■​ Business Category 
■​ Contact Information 

Step 5: Start Using Your Business Portfolio 
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Conversion Tracking in Facebook? 
Conversion Tracking in Facebook (Meta) is a method to track user actions 
(conversions) after they interact with your Facebook Ads. 

 Set Up Meta Pixel (For Websites) 

What is Meta Pixel? 

Meta Pixel is a small piece of code that you add to your website to track user 
interactions. 

How to Set Up Meta Pixel? 

●​ Click on "All Tools" → Select "Events Manager" 

 

 

 

Create a New Pixel 

●​ Click "Connect Data Sources" → Select "Web" 
●​ Click "Meta Pixel" → Continue 
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●​ Name your Pixel and enter your website URL 

 

Get Your Meta Pixel Code 

 Copy the Pixel Code 

●​ After creating the Pixel, click "Install Code Manually". 
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●​ You will see a JavaScript code snippet. 
●​ Click "Copy Code". 

 

 Add the Pixel Code to Your Website 

●​ Log in to WordPress Admin. 
●​ Go to Appearance → Theme Editor. 
●​ Open header.php file. 
●​ Paste the Pixel Code inside <head>...</head>. 
●​ Click "Update File". 

Create a Custom Conversion in Facebook Events Manager 

Create a Custom Conversion 

●​ Click "Custom Conversions" in the left panel. 
●​ Click "Create Custom Conversion". 

Define the Custom Conversion 

●​ Name: "ODMT Form Submission" (or any relevant name). 
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●​ Data Source: Select your Meta Pixel. 
●​ Conversion Event: Select "All URL Traffic". 
●​ Rules: 

○​ Choose "URL contains" 
○​ Enter: thank-you (or the exact page where users land after 

submitting a form). 

Save and Finish 

●​ Click "Create" to save your Custom Conversion. 

 

Facebook Remarketing: 
Remarketing (Retargeting) in Facebook is a strategy where you show ads to 
people who have already visited your website, engaged with your posts, or 
interacted with your business but haven’t converted yet (e.g., didn’t purchase, 
sign up, or complete a form). 
 
Create a Custom Audience for Remarketing 
A Custom Audience allows you to target people based on their interactions with 
your website, app, or social media pages. 

Create a Custom Audience in Facebook Ads Manager 

●​ Go to Facebook Ads Manager. 
●​  Click Audiences in the left panel. 
●​  Click Create Audience → Select Custom Audience. 
●​ Choose how you want to track users (Website, Facebook Engagement, or 

Customer List). 

Common Remarketing Audiences You Can Create: 

 Website Visitors: 

●​ Target people who visited your website in the last 30, 60, or 90 days. 
●​ Example: People who visited www.yoursite.com but didn’t buy. 
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Specific Page Visitors: 

●​ Target people who viewed a specific course or service page. 
●​ Example: URL contains "course-details". 

 People Who Added to Cart (But Didn’t Buy): 

●​ Target visitors who added a product to cart but didn’t complete checkout 

Click “Create” to save your audience. 

Create a Remarketing Campaign in Facebook Ads Manager 

Now, let’s run an ad campaign to retarget these users. 

Go to Facebook Ads Manager → Click Create.​
Select the "Sales" or "Traffic" campaign objective.​
Choose "Website" as your conversion location.​
Under Audience, select the Custom Audience you just created.​
Set your Budget & Schedule (start with a small budget, e.g., $10/day).​
Choose your Ad Format (Image, Video, or Carousel).​
Click Publish to start the campaign. 

 

 

LinkedIn Marketing 
LinkedIn Marketing is the process of promoting your business, products, or 
services on LinkedIn to reach professionals, business owners, and 
decision-makers. It includes strategies like organic content marketing, 
LinkedIn Ads, networking, and lead generation to grow brand awareness and 
drive sales. 
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Linkedin Advertisement structure 

 

 

 

How to Create a LinkedIn Business Page (Step-by-Step 
Guide) 
 Step 1: Log in to LinkedIn 

Go to LinkedIn.com and log in to your account.​
Click on the “Work” icon (grid icon) in the top right corner.​
Scroll down and select “Create a Company Page”. 
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Step 2: Choose Your Page Type 

Step 3: Fill in Business Details 

 Step 4: Upload Your Company Logo & Banner Image 

Step 5: Click “Create Page” 
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How to create campaign in linkedin 
Step 1: Define Your Goals & Audience 
Goal: Increasing brand awareness (followers, engagement, website visits). 

Step 2: Create a New Campaign 

●​ Click on "Campaigns" in the top navigation. 
●​ Click "Create Campaign" 

Step 3: Choose a Campaign Group 

●​ Campaigns are organized into groups. 
●​ Either use an existing campaign group or create a new one. 
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Step 4: Set Campaign Objective 

●​ Choose an objective based on your goal: 
○​ Awareness: Brand awareness 

 

Step 5: Define Target Audience 

●​ Location: Select the geographic area. 
●​ Audience Attributes: 
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○​ Job title, company name, industry, seniority, skills, etc. 
○​ Use Matched Audiences for retargeting. 

 

Step 6: Select Ad Format 

●​ Sponsored Content (single image, carousel, video) 
●​ Message Ads (direct messages) 
●​ Text Ads (sidebar ads) 
●​ Dynamic Ads (personalized ads) 
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Step 7: Set Budget & Schedule 

●​ Budget options: 
○​ Daily budget (e.g., $10/day) 
○​ Total budget (e.g., $500 total) 
○​ Bidding options: Automated, CPC (cost-per-click), CPM 

(cost-per-impression) 
●​ Schedule: Choose start and end dates. 

 

Step 8: Create Ad & Upload Media 

●​ Write engaging ad copy. 
●​ Upload relevant images, videos, or carousel slides. 
●​ Add a call-to-action (CTA) like "Learn More", "Download", or "Sign Up". 

Step 9: Review & Launch 

●​ Check settings, budget, and targeting. 
●​ Click "Launch Campaign". 
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Lead Generation Campaign in LinkedIn Ads Manager 

Step 1: Click "Create" to Start a New Campaign 

1.​In the Campaigns tab, click the "Create" button. 
2.​Choose "Campaign" from the dropdown. 

Step 2: Choose "Lead Generation" as Your Campaign Objective 

●​ LinkedIn provides different objectives. 
●​ Select "Lead Generation", as you want to collect leads (e.g., emails, 

phone numbers). 
●​ Click "Next". 

 

Step 3: Set Up Your Campaign 

●​ Campaign Name: Enter a name (e.g., "Lead Form - Marketing Leads"). 
●​ LinkedIn Page: Select your business page. 
●​ Campaign Group: Choose an existing group or create a new one. 
●​ A/B Testing (Optional): Enable if you want to test different versions. 
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Step 4: Set Up Your Ad Set (Targeting & Budget) 

Ad Set Name 

●​ Choose a name (e.g., "Lead Form - Target Audience 1"). 

 

Audience Targeting 

●​ Custom Audiences: Upload existing leads or retarget website visitors. 
●​ Location: Select the target country, city, or radius. 
●​ Job Titles: Target users based on their job roles (e.g., "Marketing 

Managers"). 
●​ Industries: Choose the industry relevant to your product/service. 
●​ Company Size: Filter by small, medium, or large businesses. 
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Budget & Schedule 

●​ Choose Daily Budget (e.g., $10/day) or Lifetime Budget (e.g., $500 for 30 
days). 

●​ Set a Start and End Date (if needed). 

 

Placements 

●​ LinkedIn Network (Recommended) 
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●​ Manual Placements: Choose whether to show ads on LinkedIn feeds, 
LinkedIn Audience Network, or InMail. 

Click "Next". 

Step 5: Create Your Ad 

Ad Name 

●​ Give your ad a name (e.g., "Lead Ad - Free Ebook"). 

Format 

●​ Choose from Single Image Ad, Carousel Ad, or Video Ad. 

Media 

●​ Upload an image or video (Recommended size: 1200x627px for images). 

 

 

 

Ad Copy 

●​ Primary Text: Write an engaging ad copy (e.g., "Want more marketing tips? 
Download our free guide!"). 

●​ Headline: Short and compelling (e.g., "Get Your Free Guide Now"). 
●​ Call to Action (CTA): Select “Sign Up”, “Get Offer”, or “Learn More”. 

Click "Next". 

Step 6: Create a Lead Form 

Click "Create Lead Form" and set up the following: 

Form Details 

●​ Form Name: Enter a name (e.g., "Marketing Leads - Free Ebook"). 
●​ Offer Headline: (e.g., "Get Your Free Digital Marketing Ebook!"). 
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●​ Offer Details: Briefly explain the offer (e.g., "Fill in your details to download 
our exclusive guide on digital marketing strategies."). 

Add Questions to Collect Leads 

By default, LinkedIn collects: 

●​ Full Name 
●​ Email 
●​ Company Name 
●​ Job Title 
●​ You can add custom questions (optional). 

Add Privacy Policy 

●​ LinkedIn requires a privacy policy link. 
●​ Paste the URL of your privacy policy page. 

Customize the Thank You Screen 

●​ Headline: (e.g., "Thank You! Your Free Guide is on the Way!"). 
●​ Description: (e.g., "Check your email for the download link. Our team will 

contact you soon!"). 
●​ Call-to-Action Button (Choose one): 

○​ Visit Website (Enter your website URL) 
○​ Call Business (Enter a phone number) 
○​ Download (Provide a direct link to your ebook or resource) 

Click "Save". 
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Step 7: Publish Your Ad 

●​ Review all settings. 
●​ Click "Launch Campaign" to submit the campaign for approval. 

 

Conversion Tracking in LinkedIn: 
Conversion Tracking in LinkedIn allows advertisers to measure the actions 
users take after clicking on a LinkedIn ad. It helps track website visits, form 
submissions, downloads, and purchases. 

Step 1: Log in to LinkedIn Campaign Manager 

●​ Visit LinkedIn Campaign Manager. 
●​ Select your Ad Account. 

 

Step 2: Go to Conversion Tracking 

●​ In the top navigation, click "Analyze" > "Conversion Tracking". 
●​ Click "Create a Conversion". 
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Step 3: Define Conversion Details 

Fill in the details for your conversion: 

●​ Conversion Name → (e.g., "Apply Job Tracking") 
●​ Conversion Type → Select "Apply Job" (since you are tracking job 

applications). 
●​ Set Conversion Value → (Optional) Assign a dollar value per conversion. 

Example: $50 per job application. 
●​ Time Frame → Select how long LinkedIn should count a conversion after a 

user clicks an ad. Example: 30 days (default). 
●​ Click "Next". 

 

 

Step 4: Manual Conversion Setup (Insight Tag) 

Now, you need to set up tracking using the LinkedIn Insight Tag. 

●​ Choose Preferred Tracking Method → Select "Insight Tag". 
●​ Select How to Track the Conversion: 

○​ Page Loads → Best for tracking users who visit a specific page after 
converting (e.g., a Thank You page). 
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○​ URL-Based Tracking → Enter the URL where users land after 
applying for a job (e.g., https://example.com/thank-you). 

Click "Next". 

 

Step 5: Install the Insight Tag on Your Website 

Method 1: Direct Website Installation 

●​ Copy the Insight Tag Code. 
●​ Paste it into the <head> section of your website on all pages. 
●​ Save and publish the changes. 

Step 6: Select Campaigns for Tracking 

●​ Choose which LinkedIn ad campaigns you want to track conversions for. 
●​ Click "Done". 
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Remarketing in LinkedIn Ads 
Remarketing (Retargeting) allows you to show ads to people who have 
previously interacted with your website, LinkedIn page, or ads. This helps bring 
back potential customers who didn’t convert the first time. 

Step 1: Log in to LinkedIn Campaign Manager 

●​ Go to LinkedIn Campaign Manager. 
●​ Select your Ad Account. 

 

Step 2: Go to Audiences & Create a Remarketing Audience 

●​ Click "Plan" > "Audiences". 
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●​ Click "Create audience" > "Website Audience". 

 

●​ Enter an Audience Name (e.g., "Visitors - Last 30 Days"). 
●​ Choose When Did They Engage? 

○​ Select 30 Days (Tracks people who visited your website in the past 30 
days). 

●​ Enter URL Rules: 
○​ Example: If you want to retarget visitors of your pricing page, enter: 
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■​ https://example.com/pricing 
○​ If you want to retarget all visitors, enter: 

■​ https://example.com/* 
●​ Click "Create". 

 

 

Step 3: Install LinkedIn Insight Tag for Website Tracking 

To track visitors for remarketing, install the LinkedIn Insight Tag on your website. 

 Manual Installation 

●​ Go to Analyze > Insight Tag. 
●​ Copy the Insight Tag Code. 
●​ Paste it into the <head> section of your website. 

Step 4: Create a Campaign & Select Remarketing Audience 

●​ Click "Create Campaign" in LinkedIn Ads Manager. 
●​ Select Campaign Objective (e.g., Lead Generation or Website Traffic). 
●​ In the Audience section, click "Use a Saved Audience". 
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●​ Select the Remarketing Audience created earlier. 

 

Step 5: Define Ad Creative & Launch Remarketing Ads 

●​ Choose Ad Format: Single Image, Video, or Carousel Ad. 
●​ Set Budget & Schedule: Choose Daily or Lifetime Budget. 
●​ Create Engaging Ad Copy: 

○​ Headline: "Did you forget something? Get Your Free Guide!" 
○​ CTA: "Sign Up" or "Download Now". 

●​ Click "Launch Campaign". 
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What is Email Marketing? 
Email marketing is the process of sending targeted emails to prospects and 
customers to build relationships, promote products, and drive conversions. 

Difference Between Transactional & Promotional Emails 

Transactional Emails 

Transactional emails are automated messages sent to users after they take a 
specific action on a website or app. These emails provide important information 
rather than marketing content. 

 Promotional Emails 

 Promotional emails are marketing messages sent to promote products, services, 
or special offers. 

Bounce: 
When you send an email campaign, some emails might not be delivered. This is 
called a bounce. Bounces are classified into two types: Soft Bounce and Hard 
Bounce. 

Soft Bounce: 

 A temporary delivery failure where the email could not be delivered, but the 
recipient’s email address is still valid. 

Hard Bounce 

A permanent delivery failure where the email cannot be delivered because 
the recipient’s email address is invalid or blocked. 

How to Use Mailchimp – A Practical Step-by-Step Guide 
Mailchimp is an email marketing platform that helps you create, send, and 
manage email campaigns. Follow this practical guide to start using Mailchimp 
effectively. 

287 



 

●​ Go to Mailchimp.com 
●​ Click "Sign Up Free" 

 

●​ Enter your email, username, and password 
●​ Click "Sign Up" and verify your email 
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Step 2: Create an Email List (Audience) 

Your email list (Audience) contains all the email addresses of your customers. 

 

 Create an Audience 

Click "Audience" → "Audience Dashboard"​
Click "Create Audience"​
 Enter:​
  Audience Name (e.g., "Customers List")​
  From Email Address (Your business email)​
  From Name (Your business name) 

 Add Your Contacts (Upload a File) 

  Go to "Audience" → "All Contacts"​
  Click "Add Contacts" → "Import Contacts"​
  Choose "Upload a File" (CSV format)​
  Map columns (Email, Name, Phone, etc.)​
  Click "Complete Import" 
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Step 3: Create an Email Campaign 

Start a New Campaign 

Click "Campaigns" → "Create Campaign" 

Select "Email"​
 Choose "Regular Email"​
 Enter a Campaign Name (e.g., "Spring Sale Offer")​
 Click "Begin" 
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 Set Up the Campaign Details 

  To: Select your audience (e.g., "Customers List")​
 From: Add sender name (e.g., "Your Business Name")​
 Subject Line 
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​
Step 4: Design the Email Content 

 Click "Design Email"​
  Select "Basic Layout" or "Pre-Made Templates"​
  Drag & Drop elements (Text, Images, Buttons)​
  Write your email content: 

●​ Headline: "Biggest Sale of the Year!" 
●​ Body: "Get 40% OFF on all products. Limited-time offer!" 
●​ Call-to-Action (CTA): " Shop Now" 
●​ Image: Upload a banner image (e.g., Sale Image) 
●​ Click "Save & Close" 

 

Step 5: Send or Schedule the Email 
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Forms in Mailchimp 

Creating a Signup Form in Mailchimp helps you collect email addresses and 
build your audience automatically. Follow this practical guide to create, 
customize, and share your signup form. 

Step 1: Access Signup Forms in Mailchimp 

●​  Log in to Mailchimp​
 Click on "Audience" in the top menu​
 Click "Signup Forms" under Audience​
 Select "Form Builder" 
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Step 2: Customize Your Signup Form 

The Form Builder lets you create and design your signup form. 

 Choose the Form Type 

Select "Signup Form" from the dropdown menu 

Edit the Form Fields 

 Mailchimp provides default fields (Email, First Name, Last Name)​
 You can add more fields: 

●​ Phone Number 
●​ Birthday 
●​ Custom Questions (e.g., "What’s your favorite product?") 
●​  Drag & drop to rearrange fields 

3. Customize the Form Design 

●​  Click "Design It" 
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●​  Change background color, text color, button color​
 Upload your logo or header image 

 

 

 

 

Step 3: Get the Signup Form Link 

 Once your form is ready, Mailchimp generates a unique link. 

 Click "Signup Form URL" at the top​
 Copy the link (e.g., https://eepurl.com/sampleform)​
  Share it via: 

●​ Website (Embed the form) 
●​ Social Media (Post the link) 
●​ Email Signature (Include the link) 
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Step 4: Embed the Signup Form on Your Website 

●​  If you want the form inside your website, follow these steps: 
●​ Go to "Audience" → "Signup Forms" → "Embedded Forms" 
●​  Copy the HTML code​

 Paste it into your website’s HTML 

Step 5: Test the Signup Form 

●​ Open the form link in a new browser tab​
Fill in details (Name, Email, etc.)​
Click "Subscribe"​
Check if the new email appears in Audience → All Contacts 

 

Tags in Mailchimp 

Tags in Mailchimp help you organize your audience by labeling contacts based 
on categories, interests, or behaviors. This allows you to send targeted 
campaigns to specific groups of subscribers. 
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Step 1: Access Tags in Mailchimp 

●​  Log in to Mailchimp​
 Click on "Audience" in the top menu​
 Click "Tags" under Audience 

Step 2: Create a New Tag 

●​ Click "Create Tag" 
●​  Enter a Tag Name (e.g., "VIP Customers", "Webinar Attendees", 

"Newsletter Subscribers")​
Click "Create" 

 

Step 3: Assign Tags to Contacts 

●​  Go to "Audience" → "All Contacts"​
 Select contacts you want to tag​
 Click "Add Tag"​
 Choose an existing tag or create a new one​
 Click "Save" 
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Step 4: Create a Campaign for a Tagged Audience 

●​ Go to "Campaigns"​
Click "Create Campaign" → Select "Email"​
Choose "Regular Email"​
Name your campaign (e.g., "Exclusive Offer for VIP Customers")​
Click "Begin" 

Step 5: Select Tagged Audience 

●​  In the "To" section, click "Edit Recipients"​
 Select "Tags"​
 Choose a specific tagged group (e.g., "VIP Customers")​
 Click "Save" 
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Step 6: Design the Email Template 

●​ Choose "Basic Layout" or a Pre-made Template​
 Add:​
 Headline: " Special Offer for VIP Customers!"​
 Body: "We appreciate you! Here’s an exclusive 20% OFF just for you."​
 Call-to-Action (CTA): " Shop Now"​
 Click "Save & Close" 

 

Step 7: Send or Schedule the Email 

●​ Click "Send Now" to send immediately​
OR Click "Schedule" to send later 

 

Step 8: Track Performance in Reports 

 Go to "Campaigns" → Click on Sent Campaign​
 Check: 
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●​ Open Rate (Who opened the email) 
●​ Click Rate (Who clicked links) 
●​ Conversions (Who made a purchase) 

Groups in Mailchimp 

Groups are a way to categorize your subscribers based on their interests, 
behavior, or any other preference. Instead of creating separate lists (which can 
be inefficient), you can segment your audience into different groups. 

Steps to View & Send Emails to a Group in Mailchimp 

Step 1: Access Your Audience & Groups 

1.​Log into Mailchimp and go to the Audience section. 
2.​Select the audience list you want to work with (if you have multiple). 
3.​Click on Manage Audience > Groups. 
4.​Find the group you want to email. 

Step 2: View a Group’s Subscribers 

●​ In the Groups section, click on the group you want to view. 
●​ You will see a list of subscribers who belong to this group. 
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Step 3: Send a Regular Email to a Group 

●​ Click on the Actions dropdown. 
●​ Select Send Regular Email. 
●​ This will take you to the email campaign creation page. 
●​ Customize your email (Subject, Content, Design, etc.). 
●​ Click Send or Schedule to send it later. 

 

Drip Campaign in Mailchimp 

A Drip Campaign (also called an Automated Email Series) is a series of 
pre-scheduled emails sent over time to engage new contacts, nurture leads, or 
onboard customers. These emails are triggered by specific actions, such as 
signing up for a newsletter or making a purchase. 

In Mailchimp, you can create a drip campaign using the Customer Journey 
feature. 

Steps to Create a Drip Campaign in Mailchimp 

 

Step 1: Access Automations & Choose Prebuilt Journey 

●​ Log in to Mailchimp and go to Automations. 
●​ Click on Create Journey. 
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●​ Choose Prebuilt Journey (these are ready-made templates for common 
automations). 

●​ Select "Welcome New Contacts" (this sends a series of welcome emails 
to new subscribers). 

●​ Click "Use This Journey" to start setting it up. 

 

Step 2: Set Date & Time Triggers 

●​ Choose when the first email should be sent after a contact subscribes: 
○​ Immediately (ideal for a welcome email). 
○​ After a few hours or days (useful for nurturing campaigns). 

●​ Click Continue to move to the next step. 

Step 3: Select an Email Template 

●​ Mailchimp provides pre-designed templates or you can create a custom 
design. 

●​ Choose a template and customize it with your brand's text, logo, and 
images. 

●​ Add a call-to-action (CTA), such as: 
○​ “Explore Our Website” 
○​ “Claim Your Discount” 
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○​ “Follow Us on Social Media” 
●​ Click Save & Continue. 

 

Step 4: Add a Journey Point (Next Email in Drip Sequence) 

●​ After the first email, you can add more emails in the sequence. 
●​ Click Add a Journey Point and select Delay (Time-Based Trigger). 
●​ Choose when the second email should be sent (e.g., 3 days after the first 

email). 
●​ Add a second email, such as: 

○​ Educational Email: "How to Make the Most of Our Services" 
○​ Product Showcase: "Best-Selling Products You’ll Love" 
○​ Discount Offer: "Here’s 10% Off Just for You!" 

●​ Repeat the process to add more emails to the sequence. 

Step 5: Review & Activate the Drip Campaign 

●​ Check the entire journey to ensure emails are scheduled correctly. 
●​ Click Start Journey to activate the campaign. 
●​ Mailchimp will automatically send emails to new contacts based on your 

schedule. 
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Segments in Mailchimp 

Segments allow you to filter and group subscribers based on specific conditions, 
such as sign-up date, location, purchase history, or even birthdays. Unlike 
Groups, which are based on subscriber choices, Segments are automatically 
created based on subscriber data. 

Steps to View & Send Emails to a Segment (e.g., Birthday Month) 

Step 1: Access Your Audience & Segments 

●​ Log into Mailchimp and go to Audience. 
●​ Select the audience list you want to work with. 
●​ Click on Manage Audience > Segments. 
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Step 2: Create a Birthday Month Segment 

●​ Click Create Segment. 
●​ Use the dropdown to select Birthday (Months). 
●​ Choose the month (e.g., "March" for people with birthdays in March). 
●​ Click Preview Segment to see how many subscribers match the criteria. 
●​ Save the segment if you want to reuse it later. 

Step 3: Send a Regular Email to the Birthday Segment 

●​ After creating the segment, click on Actions > Send Regular Email. 
●​ This will take you to the email campaign creation page. 
●​ Customize your email: 

○​ Subject: “Happy Birthday! A Special Gift for You!” 
○​ Body: Include a discount code, special message, or personalized 

offer. 
●​ Click Send or Schedule the email to go out at the beginning of the month. 
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Affiliate Marketing 
Affiliate marketing is when someone promotes another person or company's 
products and earns a commission for each sale. It's a way for publishers, 
content creators, and digital marketers to make money.  
Affiliates earn a commission for each sale, click, or lead they generate through 
their unique referral link. 

Promote the Product or Service 

●​ Share your affiliate link through: 
○​ Blog posts (e.g., “Best Laptops for Students”) 
○​ YouTube videos (e.g., “Top 5 Laptops Review”) 
○​ Social media (Instagram, Twitter, Facebook) 
○​ Email marketing 

●​ Use engaging content like reviews, tutorials, and comparisons to attract 
buyers. 

Affiliate marketing can be done in two main ways: 

●​ Direct Affiliate Marketing (One-to-One Promotion) 
●​ Mediator Affiliate Marketing (Using a Third-Party Platform) 
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What is Direct Affiliate Marketing? 

This method involves directly partnering with a company’s affiliate program 
without using any third-party network. The affiliate (you) gets a unique referral 
link from the company and promotes their products directly. 

What is Mediator Affiliate Marketing? 

This method involves using an affiliate network (a middleman) to connect with 
multiple brands. Instead of signing up directly with each company, you join an 
affiliate network that provides thousands of products to promote. 

How to Create an Amazon Associates Account (Step-by-Step Guide) 

Amazon Associates is Amazon’s affiliate marketing program, where you earn 
commissions by promoting Amazon products using affiliate links. 

Step-by-Step Process to Create an Amazon Associates Account 

Step 1: Visit the Amazon Associates Website 

●​ Open your browser and go to Amazon Associates. 
●​ Click Sign Up (If you don’t have an Amazon account, create one first). 
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Step 2: Sign in or Create an Amazon Account 

●​ If you already have an Amazon account, log in using your email and 
password. 

●​ If not, click Create Your Amazon Account and enter: 
○​ Your name 
○​ Email address 
○​ Password 

●​ Click Create Account and verify your email. 
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Step 3: Enter Your Account Information 

●​ Who Will Receive Payments? 
○​ Select "Individual" if you are doing this as a personal account. 
○​ Select "Business" if you are registering as a company. 

●​ Enter Your Personal or Business Details (Full name, address, and phone 
number). 

●​ Click Next. 

 

Step 4: Add Your Website, Blog, or Social Media 

●​ Amazon needs to know where you will promote their products. 
●​ Enter your: 

○​ Website URL (if you have a blog or online store). 
○​ YouTube Channel link (if you create review videos). 
○​ Instagram, Facebook, TikTok, or Twitter link (if you promote on 

social media). 
●​ Click Next after entering your platforms 
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Step 5: Choose Your Niche & Marketing Methods 

●​ What is Your Website or Content About? 
○​ Choose your main category (e.g., Electronics, Fashion, Health & 

Beauty). 
●​ How Will You Drive Traffic? 

○​ Select how you will promote Amazon products (SEO, Social Media, 
Blog, Email Marketing, etc.). 

●​ Click Next. 

310 



 

 

Step 6: Create Your Amazon Associates ID 

●​ Choose a unique Store ID (this is usually your name or brand name). 
●​ Enter a brief description of how you plan to promote Amazon products. 
●​ Click Next. 

Step 7: Enter Your Payment & Tax Details 

●​ Choose how you want to get paid: 
○​ Direct bank transfer (for certain countries). 
○​ Amazon gift cards (for US-based accounts). 
○​ Check (Paper Cheque) (takes longer). 

●​ Fill in Tax Information (Amazon will ask for tax details based on your 
country). 

●​ Click Submit & Finish. 

Step 8: Start Generating Affiliate Links 

To start earning: 

●​ Go to Amazon Associates Dashboard. 
●​ Search for any product you want to promote. 
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●​ Click Get Link and copy the unique affiliate link. 
●​ Share it on your blog, YouTube, Instagram, Facebook, or website. 

 

 When someone buys through your link, you earn a commission! 

How to Create an EarnKaro Account (Step-by-Step Guide) 

EarnKaro is an affiliate marketing platform in India that allows you to earn money 
by sharing affiliate links for products from Amazon, Flipkart, Myntra, Ajio, and 
more. You earn a commission every time someone makes a purchase using your 
link. 

Step-by-Step Guide to Creating an EarnKaro Account 

Step 1: Visit the EarnKaro Website or Download the App 

●​ Open your browser and go to www.earnkaro.com. 
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Step 2: Sign Up for a Free Account 

●​ Click Sign Up (top-right corner on the website). 
●​ Enter your details: 

○​ Full Name 
○​ Mobile Number 
○​ Email Address 
○​ Password 

●​ Click Create Account. 
●​ Verify your mobile number with an OTP sent to your phone 

313 



 

 

Step 3: Choose Products & Generate Affiliate Links 

●​ Go to "Make Links" Section in EarnKaro. 
●​ Copy a product link from any supported retailer (Amazon, Flipkart, Myntra, 

etc.). 
●​ Paste the link into the EarnKaro app/website. 
●​ Click "Convert Link" to generate your unique Profit Link (affiliate link). 
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What is Influencer Marketing? 
Influencer marketing is a digital marketing strategy where brands collaborate 
with social media influencers to promote their products or services. It helps 
businesses reach target audiences through trusted personalities 
 
Influencers = People with a large and engaged social media following. 
Brands pay influencers to promote their products via Instagram, YouTube,etc. 
Followers trust influencers, leading to higher sales & brand awareness. 

What is Google AdSense? 
Google AdSense is a free advertising program by Google that allows website 
owners, bloggers, and YouTubers to earn money by displaying ads on their 
content. When visitors click on these ads, you earn money. 

Step 1: Sign Up for Google AdSense 

●​ Go to Google AdSense. 
●​ Click Sign Up and log in with your Google account. 
●​ Enter your Website URL (Example: www.yourwebsite.com). 
●​ Select your Country and accept Google’s AdSense terms. 
●​ Click Create Account. 
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Step 2: Add Your Website to AdSense 

●​ Go to your AdSense Dashboard. 
●​ Click on Sites > Add Site. 
●​ Enter your website URL and click Next. 
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Step 3: Get AdSense Code & Add It to Your Website 

After adding your site, AdSense will provide a verification code. 

●​ Paste the AdSense Code into the <head> section of your website. 
●​ Go to WordPress Admin Panel → Appearance → Theme Editor. 
●​ Open header.php file and paste the code inside the <head> tag. 
●​ Save changes. 

 

Step 4: Request Google AdSense Approval 

After adding the code: 

●​ Go back to your AdSense account. 
●​ Click Submit for Review. 
●​ Google will review your site (this takes 1-2 weeks). 
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Step 5: Start Displaying Ads on Your Website 

Once Google approves your AdSense account, ads will start showing on your 
website automatically! 

 To customize your ads: 

●​ Go to AdSense Dashboard > Ads. 
●​ Choose Auto Ads or Manual Ads. 
●​ For manual ads, place the ad code inside blog posts or sidebars. 

What is Google Analytics?  
Google Analytics is a free web analytics tool by Google that helps website 
owners track and analyze website traffic. It provides insights into: 

 How many people visit your website?​
 Where do your visitors come from (Google, Facebook, etc.)?​
 What pages do visitors view the most?​
 How long do visitors stay on your site?​
 Which keywords bring traffic to your site? 
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How to Use Google Analytics (Step-by-Step Guide) 

Step 1: Create a Google Analytics Account 

●​ Go to Google Analytics. 
●​ Click Sign Up and log in with your Google account. 
●​ Click Start Measuring. 

 

Step 2: Set Up Your Website in Google Analytics 

●​ Enter your Website Name (e.g., My Blog). 
●​ Select your Industry Category (e.g., Business, Travel, etc.). 
●​ Choose your Time Zone and Currency. 
●​ Click Next to create a Google Analytics Property. 
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Step 3: Get Your Google Analytics Tracking Code 

●​ After setup, Google Analytics will provide a Tracking ID (e.g., 
G-XXXXXXXXXX). 

●​ Copy the Google Analytics tracking code. 

Step 4: Add Google Analytics to Your Website 

●​ Open your website’s Theme file Editor. 
●​ Paste the Google Analytics tracking code inside the <head> section. 

 

Step 5: Track Website Traffic in Google Analytics 

●​ Go to Google Analytics Dashboard.​
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●​ Click on Reports > Realtime to see live visitors.​
 

●​ Click on Audience > Overview to check:​
 

○​ Total visitors per day, week, month  
○​ Top countries visiting your site  
○​ Devices used (Mobile/Desktop)  

 

●​ Click on Acquisition > Overview to see:​
 

○​ How visitors find your website (Google, Facebook, Direct, etc.). 
○​ Top referral sources. 

●​ Click on Behavior > Site Content to track:​
 

○​ Which pages get the most traffic? 
○​ How long visitors stay on each page? 
○​ Bounce rate (how many people leave quickly)? 
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